W3C home > Mailing lists > Public > whatwg@whatwg.org > August 2013

Re: [whatwg] Comments on <dialog>

From: Ian Hickson <ian@hixie.ch>
Date: Tue, 27 Aug 2013 00:40:12 +0000 (UTC)
To: Ryosuke Niwa <rniwa@apple.com>
Message-ID: <alpine.DEB.2.00.1308270030250.28417@ps20323.dreamhostps.com>
Cc: Matt Falkenhagen <falken@chromium.org>, whatwg@lists.whatwg.org
On Mon, 26 Aug 2013, Ryosuke Niwa wrote:
> On Apr 22, 2013, at 12:38 PM, Ian Hickson <ian@hixie.ch> wrote:
> > 
> > The current naming is based on window.showModalDialog() and 
> > window.close(). I agree the naming is weird, but being consistent is 
> > probably going to be more helpful on the long run.
> 
> But that's because we have window.open but not an equivalent of 
> window.close for window.showModalDialog, right?
> 
> It seems more consistent to use show/hide or open/close as Matt 
> suggested.

Consistent with what? We have window.open()/window.close, and 
window.showModalDialog()/window.close(). We also have 
document.open()/document.close(), and so on (EventSource, etc). I suppose 
we could change show() to open(), but then we'd be inconsistent with 
showModalDialog() for openModal()...

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Tuesday, 27 August 2013 00:40:46 UTC

This archive was generated by hypermail 2.3.1 : Monday, 13 April 2015 23:09:23 UTC