W3C home > Mailing lists > Public > whatwg@whatwg.org > September 2012

[whatwg] [canvas] Path object

From: Elliott Sprehn <esprehn@gmail.com>
Date: Sat, 22 Sep 2012 21:17:58 -0700
Message-ID: <CAPJYB1gPU=t5N-CKtYeBVaPOXcuTYRv-AooAMyNFTAA8apnw2A@mail.gmail.com>
To: WHATWG <whatwg@whatwg.org>
I was looking at the canvas Path API and had some concerns. In
particular it's inconsistent with the rest of canvas:

We already have CanvasGradient and CanvasPattern in the global
namespace, so this should probably be called CanvasPath.

We also have createLinearGradient() and createPattern(), but this new
thing is "new Path".

Could we get some consistency here? Like adding new CanvasGradient()
(or a createPath() method) to match up with Path and renaming this
thing CanvasPath?

- Elliott
Received on Sunday, 23 September 2012 04:19:06 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 30 January 2013 18:48:10 GMT