W3C home > Mailing lists > Public > whatwg@whatwg.org > March 2009

[whatwg] fileList vs files

From: Biju <bijumaillist@gmail.com>
Date: Thu, 26 Mar 2009 23:26:00 -0400
Message-ID: <4a27dd80903262026g6f7d891cne94eacc6a8885a86@mail.gmail.com>
>>>
   I have a poor memory,
   hence not good in spelling,
   if there is not much gain with a change,
   i wish every thing follow a similar pattern
   and with short spelling,
   which make my life little easier.
<<<

On "C:\fakepath\" in HTML5 thread Anne mentioned "fileList" for <input
type=file multiple>

On Tue, Mar 24, 2009 at 10:15 AM, Anne van Kesteren <annevk at opera.com> wrote:
> application developers...) Furthermore, once we get interoperable support
> for <input type=file multiple> and the fileList proposal starts moving we

Can we call it "files" instead of fileList, this will make it
consistent with existing names like

arguments
document.links
selection_element.options
document.plugins
document.embeds
document.anchors
document.forms
document.applets
document.images

on firefox we fixed it
https://bugzilla.mozilla.org/show_bug.cgi?id=405741
Received on Thursday, 26 March 2009 20:26:00 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 30 January 2013 18:47:49 GMT