W3C home > Mailing lists > Public > whatwg@whatwg.org > December 2008

[whatwg] usemap="" and related issues

From: Ian Hickson <ian@hixie.ch>
Date: Mon, 1 Dec 2008 08:36:01 +0000 (UTC)
Message-ID: <Pine.LNX.4.62.0812010835440.17401@hixie.dreamhostps.com>
On Mon, 1 Dec 2008, Jonas Sicking wrote:
> >>
> >> Try the following markup in firefox:
> >>
> >> <map name="foo"></map>
> >> <map name="foo">
> >>  <area shape=circle coords="10,10,10" href="http://www.mozilla.com">
> >> </map>
> >> <img src="http://www.mozilla.org/images/feature-logos1.png"
> >>     usemap="#foo" width="20" height="20">
> >
> > This only seems to occur in quirks mode, not in standards mode.  But neither
> > Opera, Safari or IE8 have the same behaviour.  Additionally, the site
> > reported in the bug you mentioned no longer suffers from the bug. Therefore,
> > it doesn't appear to be necessary that we should require that behaviour.
> 
> Ah, it does indeed only happen in quirks mode (ugh, i hate it when 
> quirks mode things spread into code that I work on ;) ). If no other 
> browser is doing it in standards mode either I'm more than happy to not 
> have it in the spec.

The spec is including quirks-mode requirements; do other browsers do it in 
quirks mode?

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Monday, 1 December 2008 00:36:01 UTC

This archive was generated by hypermail 2.3.1 : Monday, 13 April 2015 23:08:46 UTC