W3C home > Mailing lists > Public > whatwg@whatwg.org > October 2007

[whatwg] looping APIs for <video>

From: Randy Drielinger <Randy@ProWebDesign.nl>
Date: Fri, 19 Oct 2007 12:32:09 +0200 (CEST)
Message-ID: <8422.217.166.50.214.1192789929.squirrel@btm909.a61.nl>
The terminoly we currently have is the one that's being used in the Video
/ Editting branch.

Although they don't sound too logical, we could keep these (thus making it
more consistent definition-wise) or perhaps pursue another name set from
an area and adapt those. I don't favor creating a new named set to make
things clear only for HTML5.0 sake.

A colleague pointed me to the naming convention for CD players:

play
loopfrom
loopcount
loopto
stop
loop

Maybe that's a more logical name set? *I don't have a final opinion yet*

>
> Several people have proposed changing the names of the looping API members
> of media elements.
>
> Currently we have
>
>    start
>    loopstart
>    loopcount
>    loopend
>    end
>    currentloop
>
> The suggestions are:
>
>    start
>    repeatfrom
>    repeatcount
>    repeatto
>    end
>    currentloop
>
>    start
>    loopfrom
>    playcount
>    loopto
>    end
>    currentloop
>
> ...and other such names. At the risk of starting a bikeshed discussion,
> what names do people prefer? I'm especially interested in the opinions of
> those of you either implementing these APIs or writing video playback
> scripts on HTML pages today.
>
> --
> Ian Hickson               U+1047E                )\._.,--....,'``.    fL
> http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
> Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
>
Received on Friday, 19 October 2007 03:32:09 UTC

This archive was generated by hypermail 2.3.1 : Monday, 13 April 2015 23:08:37 UTC