W3C home > Mailing lists > Public > whatwg@whatwg.org > February 2005

[whatwg] Web Forms 2 stable draft draft

From: Ian Hickson <ian@hixie.ch>
Date: Mon, 7 Feb 2005 23:20:49 +0000 (UTC)
Message-ID: <Pine.LNX.4.61.0502072315510.27753@dhalsim.dreamhost.com>
On Mon, 7 Feb 2005, [ISO-8859-1] Olav Junker Kj?r wrote:
> You write:
> > The model used by the validity  DOM attribute is not very clean, and
> > may deserve to be replaced with something that has been thought
> > through with more care
> 
> Perhaps the bit field interface could be left out.

Yeah, I'm considering it. My main reason not to just do it is that it 
would require _massive_ changes to the draft (everything is currently 
defined in terms of the bit masks, and the object is then defined in 
terms of that).


> A better solution would perhaps be to add an attribute, "isValid" to 
> ValidationState. So you could write:
> 
>  if (field1.validity.isValid) ...
> 
> Only problem is that the naming seems a bit strange. "validityState" 
> would be clearer than "validity", but also a bit more cumbersome.

That's pretty much the line of thought I had on the matter.


> Anyway, it seems a bit redundant to support both the bit field and 
> property interfaces.

I agree. Hence the comment in the status section. :-)

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Monday, 7 February 2005 15:20:49 UTC

This archive was generated by hypermail 2.3.1 : Monday, 13 April 2015 23:08:21 UTC