{add|remove}Track are confusing names

I've just had a long series of conversations about these.

RTCRtpSender addTrack(MediaStreamTrack track, MediaStream stream,
MediaStream... others);

The initial confusion here was that this was adding the track to the
provided stream (ignoring the return value).  That seems relatively
benign, except that...

void removeTrack(RTCRtpSender sender);

I don't even know where to start with this.  Where's the track?

Why not?

RTCRtpSender create[Track]Sender(MediaStreamTrack track, MediaStream
stream, MediaStream... others);
void remove[Track]Sender(RTCRtpSender sender);

Received on Tuesday, 17 March 2015 22:09:51 UTC