Re: Using tracks instead of streams

On 2013-11-12 09:54, Martin Thomson wrote:
> On 12 November 2013 00:18, Adam Bergkvist <adam.bergkvist@ericsson.com> wrote:
>> One thing that I find a bit odd is:
>>
>> pc.addSendTrack(track);
>> pc.sendTracks[0] == track; // false (different types)
>
> It's more like:
>
> pc.addSendTrack(track) === pc.sendTracks[0];

sendTracks should be called sendDooHickies in that case.

>
>> We could have the script construct a DooHickey and add it to the
>> PeerConnection.
>>
>> // A-side
>> var hickey = new DooHickey(track);
>> peerConn.addDooHickey(hickey);
>
> That seems like busy work.  It also means that you can't make the
> special linkage that a Doohickey needs with RTCPeerConnection.

That's true; the special linkage could happen when the object is added 
to the RTCPeerConnection. But then we need to prevent the script from 
adding the doohickey to other RTCPeerConnections. That's perhaps not 
super great.

/Adam

Received on Tuesday, 12 November 2013 09:26:20 UTC