Re: [webrtc-insertable-streams] Should we rename SFrameTransform and RTCRtpScriptTransform (#65)

> ```js
> transceiver.sender.transform = new SFrameTransform();
> transceiver.receiver.transform = new SFrameTransform({role: "decrypt");
> ```

Currently, you can simply do:
```js
transceiver.sender.transform = new SFrameTransform();
transceiver.receiver.transform = new SFrameTransform();
```
The 'role' is only used when using SFrameTransform as part of a JS-based pipe (see https://w3c.github.io/webrtc-insertable-streams/#sframe-transform-algorithm).

I am not a big fan of XXStream names for transforms.
For instance, https://streams.spec.whatwg.org/#rs-pipe-through first parameter name is 'transform'.
And that makes sense since it clarifies what it does: it does not create or consume data, it transforms data.

SFrameTransform mirrors well RTCRtpSender/RTCRtpReceiver 'transform' attribute name.
I would find it odd to rename sender.transform to sender.stream.
sender.transformStream would probably be ok but seems long and unnecessary precise.

-- 
GitHub Notification of comment by youennf
Please view or discuss this issue at https://github.com/w3c/webrtc-insertable-streams/issues/65#issuecomment-792580572 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Monday, 8 March 2021 08:39:11 UTC