public-webrtc-logs@w3.org from February 2018 by subject

[webrtc-pc] Add "statsended" event and surrounding machinery

[webrtc-pc] Add "statslifetimeended" event

[webrtc-pc] Add support for WebRTC Data Channel in Workers

[webrtc-pc] canInsertDTMF transitions not specified

[webrtc-pc] Change [[AssociatedMediaStreams]] to [[AssociatedMediaStreamIds]]

[webrtc-pc] Create a Dtmf internal slot and initialize it in RtpSender

[webrtc-pc] Define JSEP terms like "bundle" and "bundle-policy" in terminology section

[webrtc-pc] Do we need a "trackremoved" event?

[webrtc-pc] Does RTCRtpSender's dtmf attribute return the same object every time?

[webrtc-pc] DTMF sending: Permit only in connected status?

[webrtc-pc] DTMF should not send before connecting

[webrtc-pc] Duplicate definitions errors (following udpate to respec 19.6.0)

[webrtc-pc] Enqueue replaceTrack, and remove sync setting of track.

[webrtc-pc] Gating 'unmute' events on track with transceiver direction.

[webrtc-pc] Handle transceiver stopped between creation and description set

[webrtc-pc] Initial data channel state is inconsistent

[webrtc-pc] Invalid JSON in examples

[webrtc-pc] need to clear [[AssociatedMediaStreams]] in removeTrack?

[webrtc-pc] new commits pushed by aboba

[webrtc-pc] new commits pushed by alvestrand

[webrtc-pc] new commits pushed by vivienlacourba

[webrtc-pc] pc.addTrack/removeTrack are confusing and mostly redundant. Mark as legacy?

[webrtc-pc] Private key access?

[webrtc-pc] Pull Request: Change [[AssociatedMediaStreams]] to [[AssociatedMediaStreamIds]]

[webrtc-pc] Pull Request: Create a Dtmf internal slot and initialize it in RtpSender

[webrtc-pc] Pull Request: Enqueue replaceTrack, and remove sync setting of track.

[webrtc-pc] Pull Request: Evalution of direction not relevant for replaceTrack.

[webrtc-pc] Pull Request: Fix compatibility with ReSpec 19

[webrtc-pc] Pull Request: Fix remaining compat issue with respec 19

[webrtc-pc] Pull Request: Make initial state of dataChannel.readyState always be "connecting".

[webrtc-pc] Pull Request: Removing 'readonly' from Tranceiver's 'direction'.

[webrtc-pc] Pull Request: RTCRtpTransceiver.direction is writable.

[webrtc-pc] Pull Request: Update mandatory to implement stats based on stats dictionary renames

[webrtc-pc] Pull Request: Update webrtc-respec-ci integration following respec and Travis CI current practices

[webrtc-pc] Recycling an m= section may not remove the old transceiver's remote track from its stream

[webrtc-pc] reducing audio packet rate while track is disabled

[webrtc-pc] Removing 'readonly' from Tranceiver's 'direction'.

[webrtc-pc] replaceTrack "negotiation needed" clarification

[webrtc-pc] Respec errors uncovered by Respec-19

[webrtc-pc] RTCCertificate Interface should (or should not) be backed up.

[webrtc-pc] RTCPeerConnection lacks identity marker beyond current process

[webrtc-pc] RTCRtpSynchronizationSource.audioLevel algorithmic equality

[webrtc-pc] RTCRtpTransceiver.direction is writable.

[webrtc-pc] RTPRtcSender: provided properties to get related MediaStreamTrackId and media type

[webrtc-pc] Semi-sync replaceTrack API pre-initial-negotiation is bizarre.

[webrtc-pc] Simplify candidate interaction by allowing Null

[webrtc-pc] Transceiver kind attribute

[webrtc-pc] Update mandatory to implement stats based on stats dictionary renames

[webrtc-pc] Update SOTD text regarding multiple implementations

[webrtc-pc] WHATWG streams for data channel messages

[webrtc-pc] Whether KeyingMaterial internal slot can be stored and retrieved

[webrtc-stats] "make travissetup" does not work on mac

[webrtc-stats] "record<RTCQualityLimitationReason, double> qualityLimitationDurations" has invalid type

[webrtc-stats] Add hugeFramesSent counter to RTCVideoSenderStats dictionary

[webrtc-stats] Add hugeFramesSent to RTCVideoSenderStats

[webrtc-stats] Add per layer stats for SVC

[webrtc-stats] Add stat for inputAudioLevel, before the audio filter

[webrtc-stats] Clarify stats hierarchies

[webrtc-stats] Cleanup: reformat the sections

[webrtc-stats] Define object lifetimes and mention end-of-life emission

[webrtc-stats] Introduction to RTP stream statistics

[webrtc-stats] Is isRemote on RTCIceCandidateStats still necessary?

[webrtc-stats] Missing definition of "deleted". When exactly do stats get deleted?

[webrtc-stats] Moved trackId from RTCRTPStreamStats to RTC[In/Out]boundRTPStreamStats.

[webrtc-stats] new commits pushed by alvestrand

[webrtc-stats] new commits pushed by henbos

[webrtc-stats] new commits pushed by vivienlacourba

[webrtc-stats] Normalize RTCPeerConnection and PeerConnection

[webrtc-stats] Pull Request: Add build status icon and README minor reflresh

[webrtc-stats] Pull Request: Add hugeFramesSent to RTCVideoSenderStats

[webrtc-stats] Pull Request: Define timestamps as performance.timeOrigin + performance.now()

[webrtc-stats] Pull Request: Moved trackId from RTCRTPStreamStats to RTC[In/Out]boundRTPStreamStats.

[webrtc-stats] Pull Request: obsolete RTCIceCandidatePairStats priority

[webrtc-stats] Pull Request: Rename "mediaType" to "kind" in RTCRTPStreamStats.

[webrtc-stats] Pull Request: Rename sender/receiver/track dictionaries

[webrtc-stats] Pull Request: renaming RTCRTPStreamStats to RTCRtpStreamStats

[webrtc-stats] Pull Request: senderId and receiverId added to RTCRTPStreamStats

[webrtc-stats] Pull Request: Update webrtc-respec-ci integration following respec current practices

[webrtc-stats] Rename "mediaType" to "kind" in RTCRTPStreamStats.

[webrtc-stats] Rename RTCRTPStreamStats to RTCRtpStreamStats?

[webrtc-stats] Rename sender/receiver/track dictionaries

[webrtc-stats] Renaming RTCRTPStreamStats to RTCRtpStreamStats

[webrtc-stats] RTCCodecStats.implementation... per-codec, per-stream?

[webrtc-stats] RTCIceCandidatePairStats.priority is wrong

[webrtc-stats] Track ID doesn't make sense for remote RTCRtpMediaStream stats

[webrtc-stats] Typo - RTCLocalAudioStreamTrackStats should inherit from RTCAudioSenderStats

[webrtc-stats] Update webrtc-respec-ci integration following respec current practices

[webrtc-stats] WebIDL issue

Closed: [webrtc-pc] Define JSEP terms like "bundle" and "bundle-policy" in terminology section

Closed: [webrtc-pc] Direction is not readonly

Closed: [webrtc-pc] Do not consider direction in "need negotiation" evaluation for replaceTrack

Closed: [webrtc-pc] DTMF sending: Permit only in connected status?

Closed: [webrtc-pc] Editorial: PendingRemoteDescription is set by....

Closed: [webrtc-pc] Handle transceiver stopped between creation and description set

Closed: [webrtc-pc] Need <section> around dictionaries under RTCRtpSender

Closed: [webrtc-pc] Need <section> around RTCIceTransport dictionaries

Closed: [webrtc-pc] need to clear [[AssociatedMediaStreams]] in removeTrack?

Closed: [webrtc-pc] Respec errors uncovered by Respec-19

Closed: [webrtc-pc] Simplify candidate interaction by allowing Null

Closed: [webrtc-pc] Transceiver kind attribute

Closed: [webrtc-pc] Update SOTD text regarding multiple implementations

Closed: [webrtc-stats] "record<RTCQualityLimitationReason, double> qualityLimitationDurations" has invalid type

Closed: [webrtc-stats] Add hugeFramesSent counter to RTCVideoSenderStats dictionary

Closed: [webrtc-stats] Cleanup: reformat the sections

Closed: [webrtc-stats] Define timestamps in terms of performance.origin

Closed: [webrtc-stats] Is keeping stats around a memory problem?

Closed: [webrtc-stats] Missing definition of "deleted". When exactly do stats get deleted?

Closed: [webrtc-stats] Rename RTCRTPStreamStats to RTCRtpStreamStats?

Closed: [webrtc-stats] Rename sender/receiver/track stats

Closed: [webrtc-stats] RTCIceCandidatePairStats.priority is wrong

Closed: [webrtc-stats] RTCRTPStreamStats should have senderId/receiverId

Closed: [webrtc-stats] terminology: rename mediaType to kind

Closed: [webrtc-stats] Track ID doesn't make sense for remote RTCRtpMediaStream stats

Closed: [webrtc-stats] Typo - RTCLocalAudioStreamTrackStats should inherit from RTCAudioSenderStats

Closed: [webrtc-stats] WebIDL issue

Last message date: Wednesday, 28 February 2018 15:41:30 UTC