W3C home > Mailing lists > Public > public-webplatform@w3.org > May 2014

Re: Documenting APIs and bug #15

From: Renoir Boulanger <renoir@w3.org>
Date: Wed, 07 May 2014 08:12:36 -0700
Message-ID: <536A4D64.5070801@w3.org>
To: Dominique Hazael-Massieux <dom@w3.org>, Eliezer Bernart <eliezer.bernart@gmail.com>
CC: public-webplatform@w3.org
Hi Dominique,

Indeed, its a big issue and I forgot about that one.

Can you tell me if it gets improved when you try on the /upgrade/ namespace?

I'm not working on templating issues these days, but maybe somebody else
(Eliezer?) would find something to do?

  [0]: http://docs.webplatform.org/upgrade/dom/Navigator/getUserMedia

Renoir
~


On 2014-05-07, 6:51 AM, Dominique Hazael-Massieux wrote:
> Hi,
>
> Bug #15 [1] highlights a killer bug for documenting APIs: it means that
> when you document the parameters of a given method, the parameters are
> not displayed in the correct order, making the documentation basically
> misleading.
>
> While the bug is reported on the canvas API, it applies really to any
> method documentation, making WPD pretty much unusable for documenting
> APIs.
>
> I've suggested a couple of possible approaches to fix this in [1] (none
> great unfortunately); but since I haven't seen much activity on this,
> and given how critical the bug seems to me, I thought I would raise
> attention to it on the list as well.
>
> Dom
>
> 1. http://project.webplatform.org/tmpl/issues/15



Received on Wednesday, 7 May 2014 15:12:40 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:21:01 UTC