W3C home > Mailing lists > Public > public-webplatform@w3.org > July 2013

Re: JavaScript page naming, round B

From: PhistucK <phistuck@gmail.com>
Date: Fri, 12 Jul 2013 12:57:55 +0300
Message-ID: <CABc02_KtPp18Fd3=yeyGnJY8rH1yLoazL4YdDypB+UmGOgOi1Q@mail.gmail.com>
To: Max Polk <maxpolk@gmail.com>
Cc: Julee <julee@adobe.com>, Webplatform List <public-webplatform@w3.org>
I believe we have settled on "javascript" (versus "js"), since
http://docs.webplatform.org/wiki/javascript exists and
http://docs.webplatform.org/wiki/js does not, so "javascript" is the top
level.

Regarding the "objects" level... I still think it should be "Global", for
correctness and accuracy reasons. I am not an authority here, anyway, so
others have to agree in order to make this a consensus (but I feel like I
am the only one with this "Global" opinion).


☆*PhistucK*


On Fri, Jul 12, 2013 at 4:40 AM, Max Polk <maxpolk@gmail.com> wrote:

>  The first link:
>
> http://lists.w3.org/Archives/Public/public-webplatform/2012Nov/0161.html
> Conveys the principle:
>     Remove the "intermediate" pages (objects, events, methods, and
> properties)
>     from the namespace to keep the URLs shorter:
> Format:
>     apis/nameOfApi/apiObject/(event|method|property)
> Example:
>     apis/webrtc/MediaStreamTrackList/length
> Listing page for all things in the api:
>     apis/nameOfApi
> And that does seem to be fully contained in:
>     http://docs.webplatform.org/wiki/WPD:Creating_API_pages
>
>
> The second link and it's follow on discussion:
>
> http://lists.w3.org/Archives/Public/public-webplatform/2013Feb/0071.html
> Asks a question about combining content for event/property magic:
>     apis/indexeddb/IDBTransaction/onerror
>     apis/indexeddb/IDBTransaction/error
> But no such magic is defined by the JavaScript language.
>
>
> I'm ignoring the architecture page since it's marked as old:
>     http://docs.webplatform.org/wiki/WPD:Architecture
> I'm ignoring the 48K "mother of all index pages" since it has spotty
> coverage of JavaScript:
>     http://docs.webplatform.org/wiki/WPD:Content/Topic_Hierarchy
>
>
> So I believe we are now in agreement.  This page seems like the true
> reference:
>     http://docs.webplatform.org/wiki/WPD:Content/Reference_articles
> And we are here for page names:
>     js/operators
>     js/statements
> And all I need to do is add:
>     js/objects
>
> That leaves two decisions left to vote on:
>
> Decision 1: use "js" or "javascript" as the top-level?
>     js/operators    --versus--    javascript/operators
>     js/statements --versus--    javascript/statements
> Decision 2: accept "js/objects" as the parent of all built-in objects of
> importance:
>     javascript/objects
>
>
>
> On 7/11/2013 2:05 AM, PhistucK wrote:
>
>  Actually, I am not sure the pages to which you linked are up to date or
> reflect the future we want to have, but maybe the current situation (before
> the MSDN import).
>
>  The discussions I could find -
> http://lists.w3.org/Archives/Public/public-webplatform/2012Nov/0161.html
>  http://lists.w3.org/Archives/Public/public-webplatform/2013Feb/0071.html
>
>  It looks like every such discussion did not result in any action (a wiki
> update) or in total agreement. Perhaps it was discussed further in the
> content meetings that (I think) Julee had back then, I did not participate
> in those.
>
> ...[clip]...
>
>
>
Received on Friday, 12 July 2013 09:59:02 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:20:52 UTC