W3C home > Mailing lists > Public > public-webplatform@w3.org > July 2013

Re: Page naming for MSDN JS import

From: PhistucK <phistuck@gmail.com>
Date: Tue, 2 Jul 2013 21:05:41 +0300
Message-ID: <CABc02_KGeUMh_iGDAvOG2Niwneco-4HU5eeKox-Nk+c=xLFy_g@mail.gmail.com>
To: Max Polk <maxpolk@gmail.com>
Cc: Webplatform List <public-webplatform@w3.org>
Thank you very much.
Like I mentioned a few times before, all of the " Function"/" Method"/"
Property" (and similar) suffixes should be dropped.

I am a bit uncomfortable with the top level Objects path, but I guess we
must have something like that... perhaps it should be named Global, because
all of these entities are really properties/methods of the Global object.

Objects/Array/Array.isArray Function (and similar) should just be
Objects/Array/isArray.

I am not sure the top level Constants page is necessary.
I would consolidate all of the "x Constants" pages with their respective x.
For example, E should be listed (without a link, perhaps it should be a
named anchor so other pages could link to it) within the Math page.


☆*PhistucK*


On Tue, Jul 2, 2013 at 8:50 PM, Max Polk <maxpolk@gmail.com> wrote:

> This is the page naming plan for the MSDN JS imported web pages.
>
> The converted wiki pages are ready for upload.  This plan describes
> how they should be named.
>
> Currently, the top-level hierarchy is:
> * Objects
> * Constants
> * Properties
> * Functions
> * Methods
> * Operators
> * Statements
> * Directives
> * Errors
> * Reserved Words
> * Future Reserved Words
>
> Within each hierarchy are kinds of each, like kinds of Objects or
> kinds of Statements.
>
> These pages listed below don't requre much discussion.  They can be
> organized into subpages or incorporated into some subpage easily:
>
> * "Directives" has a single directive subpage "use strict" which
> should not be used.
> * "Errors" has two subpages: "Run time" and "Syntax".
> * "Reserved Words" is a single page that lists words that are already used.
> * "Future Reserved Words" is a single page that lists words that might be
> used.
>
> These pages with all their subpages are the main area of discussion.
>
> * Objects
> * Operators
> * Statements
>
> Each of these is described below.
>
> Objects
> ----
> If JavaScript had classes, the Objects hierarchy would represent it.
> Instead, JavaScript only has notable Objects used mostly to create new
> instances, such as creating a new Array.  Special objects like
> "arguments" exist automatically inside a function.  Other special
> objects are Function, Global, Object.
>
> Subpages for the Array object, for example, describe each property,
> function, method, or constant the Array object has:
>
> * Array has three properties: constructor, length, and prototype.
> * Array has one function: Array.isArray.
> * Array has many methods: concat, every, filter, forEach, indexOf,
> join, lastIndexOf, map,
> pop, push, reduce, reduceRight, reverse, shift, slice, some, sort,
> splice, toString,
> unshift, and valueOf.
> * Math has a constant Math.E.
>
> Because of this, the current page naming plan is to call the Array
> Object's constructor property: "Objects/Array/constructor Property".
>
> To list what we are talking about, the list of all notable Objects are:
>
> * ActiveXObject
> * Array
> * ArrayBuffer
> * arguments
> * Boolean
> * DataView
> * Date
> * Debug
> * Enumerator
> * Error
> * Float32Array
> * Float64Array
> * Function
> * Global
> * Int8Array
> * Int16Array
> * Int32Array
> * JSON
> * Math
> * Number
> * Object
> * RegExp
> * Regular Expression
> * String
> * Uint8Array
> * Uint16Array
> * Uint32Array
> * VBArray
> * WinRTError
>
> Operators have their own page and subpages as well.  The full list of
> pages are:
>
> * Addition Assignment
> * Addition
> * Assignment
> * Bitwise AND Assignment
> * Bitwise AND
> * Bitwise Left Shift
> * Bitwise NOT
> * Bitwise OR Assignment
> * Bitwise OR
> * Bitwise Right Shift
> * Bitwise XOR Assignment
> * Bitwise XOR
> * Comma
> * Comparison
> * Compound Assignment
> * Conditional Ternary
> * delete
> * Division Assignment
> * Division
> * in
> * Increment and Decrement
> * instanceof
> * Left Shift Assignment
> * Logical AND
> * Logical NOT
> * Logical OR
> * Modulus Assignment
> * Modulus
> * Multiplication Assignment
> * Multiplication
> * new
> * Right Shift Assignment
> * Subtraction Assignment
> * Subtraction
> * typeof
> * Unsigned Right Shift Assignment
> * Unsigned Right Shift
> * void
>
> Statements each have their own page:
>
> * break
> * cc on
> * Comment
> * continue
> * debugger
> * do while
> * for
> * for in
> * function
> * if
> * if else
> * Labeled
> * return
> * set
> * switch
> * this
> * throw
> * try catch finally
> * var
> * while
> * with
>
> Now that we have full disclosure of what exists, discussion can begin
> aiming at desired format of the page and subpage names.
>
>
Received on Tuesday, 2 July 2013 18:06:50 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:20:52 UTC