W3C home > Mailing lists > Public > public-webplatform@w3.org > December 2013

Re: Second JS bulk upload

From: Renoir Boulanger <renoir@w3.org>
Date: Mon, 2 Dec 2013 13:20:39 -0500
Cc: List WebPlatform public <public-webplatform@w3.org>
Message-Id: <746E0E4F-7A15-4C06-A7D3-ADFF32375EFC@w3.org>
To: Jen Simmons <jen@jensimmons.com>
Hi Jen,

I agree with you about spaces (a.k.a.  %20).

Im sure Max already thought about what a space is in an URL :)

But the conversation is about the page name for internal reference. MediaWiki renames such name with an underscore. So spaces problem is already addressed.

As for the capitalization, we came to the same conclusion. But we are also documenting an API that has naming conventions and this is where some of us agreed to use it only for them.

Example: 

   var a = new RegExp(foo);

RegExp has a format, we agreed that the URL will respect that representation.

At the moment no content has been imported in the wiki. 

Some of us should spend some time to see the latest import Max made. It is in the test wiki here: [1]

  [1]: http://docs.webplatform.org/test/javascript

Renoir 
~

On Dec 2, 2013, at 12:16 PM, Jen Simmons <jen@jensimmons.com> wrote:

> Why are we not just making everything lowercase in the URLs? That's what I would expect as a user. 
> Also, no spaces in any URL. 
> 
> Instead of:
>   javascript/JavaScript Reference  
>   javascript/Math/Math Constants  
>   javascript/Number/Number Constants  
>   javascript/RegExp/1 9 Properties    
> 
> I would suggest this:
>   javascript/javascript_reference  
>   javascript/math/math_constants  
>   javascript/number/number_constants  
>   javascript/reg_exp/1_9_properties    
> 
> or:
>   javascript/javascriptreference  
>   javascript/math/mathconstants  
>   javascript/number/numberconstants  
>   javascript/regexp/1-9properties    
> 
> It's much easier to guess a URL if they are all consistent. I would not expect most users to be able to guess which words "should" be capitalized or not. 
> 
> More importantly, a URL like this:
>  javascript/operators/unsigned right shift assignment
> 
> gets quickly turned into:
>  javascript/operators/unsigned%20right%20shift%20assignment
> 
> Yuk.. 
> No spaces. Prevent %20.
> 
> Jen
> 
> Jen Simmons
> designer, consultant and speaker
> host of The Web Ahead
> jensimmons.com
> 5by5.tv/webahead
> twitter: jensimmons
> 
> 
> 
> On Sun, Dec 1, 2013 at 2:19 PM, Max Polk <maxpolk@gmail.com> wrote:
> On Mon, Nov 25, 2013 at 1:45 PM, Julee <julee@adobe.com> wrote:
> Hi, Max & All:
> 
> We also have the convention that the URL should be lowercase, except for
> the language elements, which should conform to the spec.
> 
> Need suggestions below.
> 
> Page renames per Julee:
> 
>   BEFORE --> AFTER
>   javascript/Objects      javascript/objects
>   javascript/Constants    javascript/constants
>   javascript/Properties   javascript/properties
>   javascript/Functions    javascript/functions
>   javascript/Methods      javascript/methods
>   javascript/Operators    javascript/operators
>   javascript/Operators/*  javascript/operators/* (all subpages)
> 
> Not modified, unless someone has a better suggestion:
> 
>   javascript/JavaScript Reference      "JavaScript Reference" capitalized
>   javascript/Math/Math Constants       "Math Constants" capitalized
>   javascript/Number/Number Constants   (same)
>   javascript/RegExp/1 9 Properties     "Properties" capitalized
> 
> Not modified, unless someone has a better suggestion.  The following are language elements that are ideas and are not named:
> 
>     javascript/Regular Expression        (note: different than Regex)
>     javascript/operators/Addition Assignment
>     javascript/operators/Addition
>     javascript/operators/Assignment
>     javascript/operators/Bitwise AND Assignment
>     javascript/operators/Bitwise AND
>     javascript/operators/Bitwise Left Shift
>     javascript/operators/Bitwise NOT
>     javascript/operators/Bitwise OR Assignment
>     javascript/operators/Bitwise OR
>     javascript/operators/Bitwise Right Shift
>     javascript/operators/Bitwise XOR Assignment
>     javascript/operators/Bitwise XOR
>     javascript/operators/Comma
>     javascript/operators/Comparison
>     javascript/operators/Compound Assignment
>     javascript/operators/Conditional Ternary
>     javascript/operators/delete
>     javascript/operators/Division Assignment
>     javascript/operators/Division
>     javascript/operators/in
>     javascript/operators/Increment and Decrement
>     javascript/operators/instanceof
>     javascript/operators/Left Shift Assignment
>     javascript/operators/Logical AND
>     javascript/operators/Logical NOT
>     javascript/operators/Logical OR
>     javascript/operators/Modulus Assignment
>     javascript/operators/Modulus
>     javascript/operators/Multiplication Assignment
>     javascript/operators/Multiplication
>     javascript/operators/new
>     javascript/operators/Right Shift Assignment
>     javascript/operators/Subtraction Assignment
>     javascript/operators/Subtraction
>     javascript/operators/typeof
>     javascript/operators/Unsigned Right Shift Assignment
>     javascript/operators/Unsigned Right Shift
>     javascript/operators/void
> 
> For all but the first above, the parent javascript/operators is fixed, but these are multiword page names, where the *lower*-case page names are JavaScript language elements (delete, in, new, typeof, void) and the upper-case page names are descriptions of the operator (to differentiate between language element and non-language element in the *reverse* sense of using case).  Whereas javascript/Math is a Math object, a javascript/operators/Division is really a "/" which is unusable as a page name, so a descriptive word "Division" is used instead.
> 
> Perhaps under operators we don't want to lower-case everything like this:
> 
>     javascript/operators/subtraction
>     javascript/operators/typeof
>     javascript/operators/unsigned right shift assignment
>     javascript/operators/unsigned right shift
>     javascript/operators/void
> 
> because the above strategy makes typeof and void (actual operators) indistinguishable from words used to describe the operators (subtraction and unsigned right shift).  Maybe that doesn't matter though since people can just read the page.
> 
> 
Received on Monday, 2 December 2013 18:20:52 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:20:56 UTC