W3C home > Mailing lists > Public > public-webont-comments@w3.org > April 2003

[closed] Re: Naming convention in OWL

From: Jim Hendler <hendler@cs.umd.edu>
Date: Tue, 15 Apr 2003 18:17:07 -0400
Message-Id: <p05200f5abac234e07f2c@[10.0.1.4]>
To: "Nikola" <nikola.stojanovic@acm.org>, <public-webont-comments@w3.org>

At 4:07 PM -0400 4/15/03, Nikola wrote:
><Jim Hendler>
>Nikola - please let us know if this message addressed your question, and
>whether you would like to see the specific words that Mike will add to the
>reference document to address this issue.
></Jim Hendler>
>
>Yes, it does. It looks to me that it would be helpful to add the explanation
>about naming convention to the reference document. As it could be hinted
>from my previous post, I was assuming (by just looking into their names that
>have common suffix "Property") that both owl:equivalentProperty and
>owl:TransitiveProperty are some kind of properties, but then there is this
>distinction in naming (lower / upper) that hinted something else.
>
>Also, should there be another rule that doesn't allow using suffix / prefix
>/ ... like "Property" in classes like owl:TransitiveProperty. Or,
>"P(p)roperty" should not be used in any names at all?
>
>NB: I am just starting with OWL / RDF / ... so I realize that I might be off
>with some of the above.
>
>Regards,
>Nikola


I'm glad Mike's response helped and answered your question.  The 
mailing list www-rdf-logic@w3.org is available for open discussion of 
RDF/RDFS/OWL issues relating to logic, properties, etc. and is a good 
place to get help as you learn the langauge - people there will be 
happy to help you out as you progress.
  -Jim H.
  WOWG chair


-- 
Professor James Hendler				  hendler@cs.umd.edu
Director, Semantic Web and Agent Technologies	  301-405-2696
Maryland Information and Network Dynamics Lab.	  301-405-6707 (Fax)
Univ of Maryland, College Park, MD 20742	  240-731-3822 (Cell)
http://www.cs.umd.edu/users/hendler
Received on Tuesday, 15 April 2003 18:17:13 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:43:27 GMT