W3C home > Mailing lists > Public > public-webont-comments@w3.org > April 2003

Re: Naming convention in OWL

From: Nikola <nikola.stojanovic@acm.org>
Date: Tue, 15 Apr 2003 16:07:39 -0400
Message-ID: <014b01c3038a$aa576410$1aea5c18@kubura>
To: <public-webont-comments@w3.org>

<Jim Hendler>
Nikola - please let us know if this message addressed your question, and
whether you would like to see the specific words that Mike will add to the
reference document to address this issue.
</Jim Hendler>

Yes, it does. It looks to me that it would be helpful to add the explanation
about naming convention to the reference document. As it could be hinted
from my previous post, I was assuming (by just looking into their names that
have common suffix "Property") that both owl:equivalentProperty and
owl:TransitiveProperty are some kind of properties, but then there is this
distinction in naming (lower / upper) that hinted something else.

Also, should there be another rule that doesn't allow using suffix / prefix
/ ... like "Property" in classes like owl:TransitiveProperty. Or,
"P(p)roperty" should not be used in any names at all?

NB: I am just starting with OWL / RDF / ... so I realize that I might be off
with some of the above.

Regards,
Nikola
Received on Tuesday, 15 April 2003 16:07:39 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:43:27 GMT