W3C home > Mailing lists > Public > public-webont-comments@w3.org > September 2002

Re: OWL working drafts - feedback

From: Peter F. Patel-Schneider <pfps@research.bell-labs.com>
Date: Sat, 07 Sep 2002 09:55:44 -0400 (EDT)
Message-Id: <20020907.095544.125121530.pfps@research.bell-labs.com>
To: pemery@grci.com
Cc: public-webont-comments@w3.org, patemery@att.com

Hi:

I'm replying to those portions of your message that are
concerned with the portion of the documents that I'm currently in charge
of.  I've elided other portions of your message; many of theses will
probably be dealt with by the other editors.

Peter F. Patel-Schneider
Bell Labs Research


From: "Emery, Pat" <pemery@grci.com>
Subject: OWL working drafts - feedback
Date: Thu, 5 Sep 2002 22:27:19 -0400 
> 
> Overall I think Owl looks good.  Some Specific comments follow.
> 
> Feature Synopsis specific comments:

[...]

> The use of Individual for "objects that belong to classes" while
> semantically correct leads very easily to confusion with its definition
> pertaining particularly to people.  The confusion is further reinforced by
> the use of people in the examples in the Feature Synopsis.  I favor the use
> of the word "Object" but other potential words to use instead of Individual
> are: Item, Thing, Entity, Occurrence, Singleton, Solitare.

A very good point.  I'm going to bring this up for consideration by the
Working Group.

[...]

> Abstra[c]t Syntax specific comments
> 
> Section 1.  Paragraph 4 first Sentence.  Seems to be in Conflict with the
> presence of Section 6 in the document.

Yes, in some sense.  Section 6 was added later.  I've revised the paragraph
to claim no ``definition'' of the exchange syntax.

> Section 1.2  First stance:  I think order is a very fundamental thing and
> should be treated as a first class issue and not left out.  The consequences
> of the decision will be users inventing individual solutions.

Agreed, but order is difficult to incorporate, particularly as RDF is
essentially unordered.  The issue does remain as an issue for the working
group.

> Section 3 First Paragraph, last sentence, substitute an for a, should read:
> associated with an ontology.
>
> Section 3 Second Paragraph, first sentence, add missing an, should read:
> which is a URI reference.
> 
> Section 3 Second Paragraph, second sentence, spelling error, should read:
> wherever possible.

OK, I'll make these changes.  :-)
Good reading, by the way.

> Section 5 First Paragraph Sentence 1. States Owl and Owl-Lite have been the
> same so far but "nothing" has been mentioned and is only present in
> Owl-Lite.

This used to be true, but the document was reordered a bit.  Thanks for
noticing.

> Section 5 Fourth Paragraph Sentence 1.  Symmetric is not listed.

Another good catch.

> Section 5.1.3 Paragraph 3.  The words don't seem to match up with the axiom.
> The words seem to "group and or" symmetric, functional and inverseFunctional
> but the axiom seems to "group and or" functional, inverseFunctional and
> Transitive.

This is partly by design, as the full conditions on when a property can be
transitive are mentioned in the next paragraph.  The ``or'' in the wording
does not mean ``at most one of''.  However, I found a better way of saying
the same thing, which happens to match the axiom better.

> Section 5.3.3 Shouldn't the third cardinality line have max-cardinality be a
> positive-integer.  Otherwise this seems to allow min>max where max=0.
> Shouldn't there be a statement additionally that states that min < max.

It is possible to state minCardinality=5 maxCardinality=4.  There will be
no instances of the restriction but this is not an error.  It doesn't help
to rule this out syntactically.

Maximum cardinality of 0 even more acceptable, as all it is stating is that
instances of the restriction have no values for the property.  This is
needed for definitions like bachelor, a man with no wife.

> Section 5.2.4 should be Section 5.3.4.

Actually 5.3.3 should be 5.2.3.

> Section 6  DataType Property. Transformation lists owl:uniqueProperty should
> be owl:FunctionalProperty?

Yes, this was an oversight as the name was changed some time ago.

[...]

> Pat Emery
Received on Saturday, 7 September 2002 09:55:55 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:43:27 GMT