W3C home > Mailing lists > Public > public-webevents@w3.org > April to June 2011

Re: WebEvents-ISSUE-11 (interface-names): Need to agree on the names of the Interfaces in the Touch Events spec [Touch Events spec]

From: Matt Brubeck <mbrubeck@mozilla.com>
Date: Sun, 24 Apr 2011 21:02:10 -0700
Message-ID: <4DB4F242.7060805@mozilla.com>
To: Web Events Working Group WG <public-webevents@w3.org>
CC: Web Events Working Group Issue Tracker <sysbot+tracker@w3.org>
If possible, we should rename the TouchPoint interface to just "Touch" 
and use "document.createTouch" as the name of the TouchPoint constructor 
(see ISSUE-8).

This improves interoperability with content that uses 
(document.createTouch) or (window.Touch) for feature detection.  This 
appears to be a common pattern in public content.  Examples:

https://github.com/johnantoni/jquery.spritely/blob/263e277000abdb4b023aa4699e50a77b6e5423c4/jquery.spritely.js#L175

https://github.com/dfabulich/choicescript/blob/e45124a20975853ca3d1a37226b41908b2cc10b2/web/ui.js#L355

http://www.google.com/codesearch/p?hl=en#3MG7X9tQ7fA/trunk/static/functions/iphone.js&q=document.createTouch&sa=N&cd=4&ct=rc&l=13
Received on Monday, 25 April 2011 04:02:40 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 25 April 2011 04:02:42 GMT