W3C home > Mailing lists > Public > public-webcrypto@w3.org > October 2012

Re: crypto-ISSUE-27 (aes ctr): Specification of AES-CTR mode counter bits [Web Cryptography API]

From: Wan-Teh Chang <wtc@google.com>
Date: Tue, 16 Oct 2012 10:58:57 -0700
Message-ID: <CALTJjxE_N-zbo1synDz+E4LWF0JeiQG15P=aUtxVKP9zkzaD1Q@mail.gmail.com>
To: Ryan Sleevi <sleevi@google.com>
Cc: Web Cryptography Working Group <public-webcrypto@w3.org>, Vijay Bharadwaj <Vijay.Bharadwaj@microsoft.com>
On Mon, Oct 15, 2012 at 9:24 AM, Ryan Sleevi <sleevi@google.com> wrote:
>
> Was there a reason for the naming change?
>
> As mentioned on previous calls, this is something that won't be able
> to be minified (the literal strings "counter" and "length" will have
> to appear in the final dictionary), thus the "counterBlock" and
> "counterBitsLength" seem... overly long?

I see. The original names are ambiguous because it isn't clear whether
"length" refers to the length of the entire counter block or the
portion that is incremented (the counter bits):

dictionary AesCtrParams : AlgorithmParameters {
  // The initial value of the counter. counter MUST be 16 bytes.
  ArrayBuffer counter;
  // The length, in bits, of the counter
  [EnforceRange] octet length;
};

We can solve this problem by improving the comments:

dictionary AesCtrParams : AlgorithmParameters {
  // The initial value of the counter block. |counter| MUST be 16 bytes.
  ArrayBuffer counter;
  // The length, in bits, of the part of the counter block that is incremented
  [EnforceRange] octet length;
};

but it would be nice to improve the name for "length", too.

Wan-Teh
Received on Tuesday, 16 October 2012 17:59:23 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 16 October 2012 17:59:25 GMT