W3C home > Mailing lists > Public > public-webcgm-wg@w3.org > October 2008

RE: ISSUE: WebCGMRect::union

From: Galt, Stuart A <stuart.a.galt@boeing.com>
Date: Thu, 2 Oct 2008 13:09:46 -0700
Message-ID: <C8D2620C74DE75488C5FDFBDB9475D6F0C53022B@XCH-NW-7V1.nw.nos.boeing.com>
To: "Bezaire, Benoit" <bbezaire@ptc.com>, "WebCGM WG" <public-webcgm-wg@w3.org>
I think that getUnion() would be similar to our other get/set routines.
But do not have very strong feelings
one way or another.




	From: Bezaire, Benoit [mailto:bbezaire@ptc.com] 
	Sent: Thursday, October 02, 2008 11:34 AM
	To: WebCGM WG
	Subject: ISSUE: WebCGMRect::union
	union() is not a good method name. Given that 'union' is a C/C++
keyword, it cannot get compiled by the MIDL compiler (on Windows).
	We need a new name. Either:
	i) Union(): but we have so far, started method names using lower
cap characters.
	ii) calcUnion() or getUnion(): or something similar.
Received on Thursday, 2 October 2008 20:11:23 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:59:30 UTC