W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2012

Re: Bikesheds Re: [selectors-api] Consider backporting find() behavior to querySelector()

From: Lachlan Hunt <lachlan.hunt@lachy.id.au>
Date: Thu, 21 Jun 2012 16:42:55 +0200
Message-ID: <4FE332EF.2040109@lachy.id.au>
To: "Kang-Hao (Kenny) Lu" <kennyluck@csail.mit.edu>
CC: "public-webapps.w3.org" <public-webapps@w3.org>
On 2012-06-21 15:56, Kang-Hao (Kenny) Lu wrote:
> (12/06/20 22:26), Lachlan Hunt wrote:
>> On 2012-06-20 10:42, Charles McCathieNevile wrote:
>>> In other words we have the same arguments that we had five years ago,
>>> when we settled on querySelector as the one that provoked least
>>> objection.
>>> ...
>>> But spending another few months arguing about it hasn't proven that we
>>> are any wiser, nor (importantly) any closer to agreement.
>>
>> This is why it should be an editorial decision, not a group vote.
>
> While I don't think a WG vote is the right way to do, I strongly
> disagree that naming of a function belongs to an editorial decision.
> Changing the name of a function requires all the tests be rewritten, and
> therefore it is by definition not editorial.

By editorial decision, I meant that the decision of what to name it 
should be up to the editor, not that it is a minor editorial issue. 
Sorry for the confusion.  Fixing tests is trivial, but the name should 
be decided before implementation begins and a testsuite is written anyway.

At this stage, I haven't seen any overly strong objections to the names 
find/findAll anyway, so hopefully this is a non-issue.

>> Hopefully, this time, the group will let me, as editor, evaluate the
>> options and supporting rationale and make a decision based on that.
>
> I don't know what happened when the WG decided on the poor name
> "querySeletor", but from a outsider's point of view, along with the
> final decision, I also care about a detailed description about why a
> function name is chosen.
>
> For example, attributing the poor "querySelector" decision to an
> abstract concept of "design by committee" doesn't seem to be reasonable
> and genuine. I'd rather want to see a long explanation like:

What happened last time was that I carefully reviewed the entire debate, 
taking into account all arguments for and against every suggested 
alternative I found at the time and posted a thorough review and 
rationale for the decision I made at the end.

http://lists.w3.org/Archives/Public/public-webapi/2007Jun/0077.html

This then resulted in some people in the group complaining loudly enough 
because they weren't happy, mostly because it's impossible to please 
everyone, leading to a vote between 6 choices, ultimately overruling me.

Anecdotally, I heard from a few web developers at the time saying they 
even liked the names I'd chosen, despite them being a little long, but 
were later disappointed with the result of the vote.

-- 
Lachlan Hunt - Opera Software
http://lachy.id.au/
http://www.opera.com/
Received on Thursday, 21 June 2012 14:43:34 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:52 GMT