W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2012

Re: [selectors-api] Consider backporting find() behavior to querySelector()

From: Charles McCathieNevile <chaals@opera.com>
Date: Wed, 20 Jun 2012 10:42:52 +0200
To: "Tab Atkins Jr." <jackalmage@gmail.com>, "Elliott Sprehn" <esprehn@gmail.com>
Cc: "Simon Pieters" <simonp@opera.com>, "Kang-Hao (Kenny) Lu" <kennyluck@csail.mit.edu>, "public-webapps.w3.org" <public-webapps@w3.org>
Message-ID: <op.wf605q1awxe0ny@widsith-3.local>
On Wed, 20 Jun 2012 06:19:22 +0200, Elliott Sprehn <esprehn@gmail.com>  
wrote:

> On Tue, Jun 19, 2012 at 1:38 PM, Tab Atkins Jr.  
> <jackalmage@gmail.com>wrote:
>
>> ...
>> This is not a good argument.  qSA is used often enough, and has a long
>> enough name, that the name is actually a pretty significant
>> misfeature.  This is a pretty core API, and both it and its precursors
>> (getElementByID, etc.) are very commonly renamed by libraries
>> precisely because you need a very short name for such a commonly used
>> function.
>
>
> Why does it need a short name? If the name is too long to type then  
> that's
> an argument for better IDEs. Otherwise you end up with stuff like strncpy
> to "save typing". gzip eliminates the file size issue.
>
> I'm in agreement with Marat that find() is not as clear as most DOM APIs
> usually are. findBySelector() makes much more sense.

In other words we have the same arguments that we had five years ago, when  
we settled on querySelector as the one that provoked least objection.

getElementsB(y)Selector is consistent with the platform, subject to  
getting the s wrong, awfully long. find is too short for a general  
platform that has lots of ways of finding things and things you might be  
finding. querySelector is just sucky.

But spending another few months arguing about it hasn't proven that we are  
any wiser, nor (importantly) any closer to agreement.

If you want quick typing, alias it. If you want to know what it does  
because you only use it once a month (or in my case about once every six  
months), the name is barely clear enough.

There are no good answers here, since there are significant and competing  
needs.

cheers

Chaals


-- 
Charles 'chaals' McCathieNevile  Opera Software, Standards Group
     je parle français -- hablo español -- jeg kan noen norsk
http://my.opera.com/chaals       Try Opera: http://www.opera.com
Received on Wednesday, 20 June 2012 08:43:40 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:52 GMT