W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2012

Re: Feedback on Quota Management API

From: Kinuko Yasuda <kinuko@chromium.org>
Date: Tue, 5 Jun 2012 22:03:55 +0900
Message-ID: <CAMWgRNYDoeOhCAw0RCFcyu4KuOUaK-C20unqqYydRpuzAWL=Rg@mail.gmail.com>
To: Tobie Langel <tobie@fb.com>
Cc: Anne van Kesteren <annevk@annevk.nl>, Boris Zbarsky <bzbarsky@mit.edu>, Web Applications Working Group WG <public-webapps@w3.org>, Eric U <ericu@google.com>
On Mon, Jun 4, 2012 at 6:30 PM, Tobie Langel <tobie@fb.com> wrote:

> On 6/4/12 11:17 AM, "Anne van Kesteren" <annevk@annevk.nl> wrote:
>
> >On Mon, Jun 4, 2012 at 11:01 AM, Tobie Langel <tobie@fb.com> wrote:
> >> Finally, I feel it's slightly misleading to have an interface called
> >> "info" which enables changes (through `requestQuota`). Wouldn't
> >>"settings"
> >> or similar be more appropriate? As in:
> >>
> >>    navigator.persistentStorageSettings.queryUsageAndQuota
> >>    navigator.persistentStorageSettings.requestQuota
> >>
> >> Thoughts?
> >
> >That seems way long. navigator.storage would be better I think. Or
> >even defining the relevant methods directly on navigator.
>
> Agreed. Whether you're targeting persistent or temp storage still needs to
> appear somewhere, however.
>
> So it's either:
>
>    navigator.persistentStorage.requestQuota
>
> or:
>
>    navigator.storage.requestPersistentQuota
>
> or:
>
>
>    navigator.requestPersistent(Storage)Quota
>
> I'd favor the first one.


I like the first one too.  The third one sounds neat too but it may become
too long for queryUsageAndQuota one (if we include Storage part).

By the way even if we take navigator.persistentStorage or persistent.storage
I'd still like to avoid using the name 'Storage' for the interface name
(which would
appear only on IDL), since we use the name for Web Storage and it's
confusing.

Maybe we could use StorageSettings for the interface name?
Or how about StorageQuota (and renaming QuotaStorageEnv to StorageQuotaEnv)?
Actually I like the latter one since it's shorter and reflects the API name
better.

--tobie
>
>
>
>
Received on Tuesday, 5 June 2012 13:10:42 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:52 GMT