W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2012

Re: [editing] input event should have a data property WAS: [D3E] Where did textInput go?

From: Aryeh Gregor <ayg@aryeh.name>
Date: Thu, 5 Apr 2012 16:19:53 +0300
Message-ID: <CAKA+AxnSf7vwJeKWNHWPzaiUH_p1BQxsfD0pJ9_mvh+_WuxjPg@mail.gmail.com>
To: Ojan Vafai <ojan@chromium.org>
Cc: Andrew Oakley <andrew@ado.is-a-geek.net>, Anne van Kesteren <annevk@opera.com>, WebApps WG <public-webapps@w3.org>
On Wed, Apr 4, 2012 at 10:07 PM, Ojan Vafai <ojan@chromium.org> wrote:
> The original proposal to drop textInput included that beforeInput/input
> would have a data property of the plain text being inserted. Aryeh, how does
> that sound to you? Maybe the property should be called 'text'? 'data' is
> probably too generic.

Sounds reasonable.  Per spec, the editing variant of these events has
.command and .value.  I think .text is a good name for the plaintext
version.  It should just have the value that the input/textarea would
have if the beforeinput event isn't canceled.
Received on Thursday, 5 April 2012 13:20:48 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:51 GMT