W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2011

Re: IndexedDB: multientry or multiEntry?

From: Jonas Sicking <jonas@sicking.cc>
Date: Wed, 30 Nov 2011 15:55:03 -0800
Message-ID: <CA+c2ei8HzdBEYqwRzSLMRQLq4Ln5ST_BHHDUx+Ao8+Z8SHTY-w@mail.gmail.com>
To: Joshua Bell <jsbell@chromium.org>
Cc: public-webapps@w3.org
On Wed, Nov 30, 2011 at 3:09 PM, Joshua Bell <jsbell@chromium.org> wrote:
> Should the parameter used in IDBObjectStore.createIndex() and the property
> on IDBIndex be spelled "multientry" (as it is in the spec currently), or
> "multiEntry" (based on "multi-entry" as the correct English spelling)?
> Has any implementation shipped with the new name yet (vs. the old
> "multirow")? Any strong preferences?

Much of HTML uses all-lowercase names for similar things, both in
markup and in the DOM.

I would actually prefer to go the other way and change autoIncrement
to autoincrement.

/ Jonas
Received on Wednesday, 30 November 2011 23:56:01 UTC

This archive was generated by hypermail 2.3.1 : Friday, 27 October 2017 07:26:37 UTC