W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2011

[Bug 14318] New: Importance of the upgradeneeded event should be more explicit

From: <bugzilla@jessica.w3.org>
Date: Tue, 27 Sep 2011 22:11:55 +0000
To: public-webapps@w3.org
Message-ID: <bug-14318-2927@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=14318

           Summary: Importance of the upgradeneeded event should be more
                    explicit
           Product: WebAppsWG
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Indexed Database API
        AssignedTo: dave.null@w3.org
        ReportedBy: me@kylehuey.com
         QAContact: member-webapi-cvs@w3.org
                CC: mike@w3.org, public-webapps@w3.org


It is never explicitly stated that the upgradeneeded event is your one chance
to modify the database schema.  This only becomes apparent after reading the
VERSION_CHANGE transaction steps in detail.  It's easy to miss this subtle
point (at least it was for me :-P).

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Tuesday, 27 September 2011 22:11:56 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:47 GMT