W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2010

Re: Issue in DIgital Signature test suite

From: Marcos Caceres <marcosc@opera.com>
Date: Thu, 02 Dec 2010 18:28:17 +0100
Message-ID: <4CF7D731.2020606@opera.com>
To: viji <viji@borqs.com>
CC: public-webapps@w3.org, Kai Hendry <kai.hendry@wholesaleappcommunity.com>, Rajshekar K <rajshekark@borqs.com>, Stuart Knightley <stuartk@opera.com>
On 12/2/10 6:35 AM, viji wrote:
> All
>
> I have created a test case using the script provided in the w3c
> test-suite. The test case is created successfully. But when I tried to
> validate the created widget using the validate script, the signature
> does not get validated.

I had Stuart take a look, and he fixed it:

"So the problem was that 2.rsa.cert.pem was not available in the 
signature files, and so the chain 3.rsa -> 2.rsa -> root.rsa was broken, 
preventing validation.

One way to fix this is to add `--untrusted-pem 2.rsa.cert.pem` to the 
command, but the better way is to add the cert to the X509Data node. 
I've updated the tools on the W3C site to automatically add all the 
certificates needed to new signatures created with 
./create-test-case.sh, so this should be a problem no more.

Stuart "


Kind regards,
Marcos
Received on Thursday, 2 December 2010 17:28:59 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:42 GMT