W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2010

Re: [progress-events] Update

From: Charles McCathieNevile <chaals@opera.com>
Date: Wed, 06 Oct 2010 01:06:09 +0200
To: "Olli Pettay" <Olli.Pettay@helsinki.fi>, Olli@pettay.fi, "Anne van Kesteren" <annevk@opera.com>
Cc: "WebApps WG" <public-webapps@w3.org>
Message-ID: <op.vj4k4jekwxe0ny@widsith.local>
On Tue, 05 Oct 2010 19:36:27 +0200, Anne van Kesteren <annevk@opera.com>  

Thanks for taking this over Anne.

> On Tue, 05 Oct 2010 19:31:12 +0200, Olli Pettay  
> <Olli.Pettay@helsinki.fi> wrote:
>> May I ask why you think the interface member names are terrible?
> I should probably have left out that comment. It is just that they are  
> inconsistent — lengthComputable vs total — and seem to imply a specific  
> kind of process — loaded. I would have preferred hasMax, value, and max  
> / hasTotal/totalKnown, current, and total or some such. Anyway, changing  
> this is not worth it.

Right. I am not overly fond of the names either. As I recall, they were  
copied from SVG where people were actually using this already, to reduce  

I agree that changing them is probably not worth the effort (or the  
bike-shedding of *exactly* what new names would be the best... I would  
vote for Sarah, John, Stuart, and Mary, because they're nice names and if  
you have a cartoon in mind of the different characters with their  
different functions they are as memorable as anything else. Which is to  
say, not actually all that much more intuitive in the grand scheme of  



Charles McCathieNevile  Opera Software, Standards Group
     je parle français -- hablo español -- jeg lærer norsk
http://my.opera.com/chaals       Try Opera: http://www.opera.com
Received on Tuesday, 5 October 2010 23:07:03 UTC

This archive was generated by hypermail 2.3.1 : Friday, 27 October 2017 07:26:28 UTC