W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2010

Re: [IndexedDB] IDBCursor.update for cursors returned from IDBIndex.openCursor

From: Jeremy Orlow <jorlow@chromium.org>
Date: Fri, 17 Sep 2010 00:06:28 +0100
Message-ID: <AANLkTimdBgifLqLEeuUgO0UsB=4O_ei3wJb1RMfs6uiK@mail.gmail.com>
To: "Tab Atkins Jr." <jackalmage@gmail.com>
Cc: Jonas Sicking <jonas@sicking.cc>, public-webapps WG <public-webapps@w3.org>
On Thu, Sep 16, 2010 at 11:04 PM, Tab Atkins Jr. <jackalmage@gmail.com>wrote:

> On Thu, Sep 16, 2010 at 2:23 PM, Jeremy Orlow <jorlow@chromium.org> wrote:
> > I think we should leave in openObjectCursor/getObject but remove
> > openCursor/get for now.  We can then revisit any of these features as
> soon
> > as there are implementations (both in the UAs and in web sites) mature
> > enough for us to get real feedback on the features.
>
> If you do so, could you migrate the names over?  No sense having a
> useless "Object" hanging around in the name.  Terse is better.
>

When I wrote that, my concern was backing ourselves into a corner in terms
of names if/when we do add back such an API.  But now that I think about it,
it seems as though the normal operation would be getting the objects (i.e.
the value in the ObjectStore) and getting just the primary key would be more
of an optimization.  So yeah, I agree that getObject->get and
openObjectCursor->openCursor is the right naming scheme here.

J
Received on Thursday, 16 September 2010 23:07:19 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:40 GMT