W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2009

Re: [widgets] about test d1.wgt

From: Marcos Caceres <marcosc@opera.com>
Date: Fri, 27 Nov 2009 13:02:23 +0000
Message-ID: <4B0FCDDF.7050105@opera.com>
To: cyril.concolato@telecom-paristech.fr, Robin Berjon <robin@berjon.com>
CC: public-webapps <public-webapps@w3.org>
Hi Cyril,

Cyril Concolato wrote:
> Hi Marcos,
>
> Marcos Caceres a écrit :
>> Hi Cyril,
>>
>> On Fri, Nov 20, 2009 at 5:50 PM, Cyril Concolato
>> <cyril.concolato@enst.fr> wrote:
>>> Hi,
>>>
>>> The test d1.wgt is about the src attribute of the icon element. It
>>> says that
>>> it tests the following assertion:
>>> "If the src attribute of this icon element is absent, then the user
>>> agent
>>> must ignore this element."
>>> but the config.xml contains an src attribute with an empty value.
>>> This seems
>>> a bit different to me. Maybe you should modify the spec as follows:
>>>
>>> "If the src attribute of this icon element is absent *or empty*, then
>>> the
>>> user agent must ignore this element."

Ok, your are totally right (sorry, I didn't get it the first time!). A 
clarification was needed there and I've added it ("or an empty string" 
was needed in the spec).

I've made two tests:

test-suite/test-cases/ta-iipTwNshRg/000/d1.wgt (absent)
test-suite/test-cases/ta-iipTwNshRg/001/ga.wgt (empty)

{Robin: you might want to retest, but I'm sure Widgeon passes}.

>>
>> Well, you get the same result when you actually search for the file
>> "", as it won't be found. But I agree, a simple clarification there
>> won't actually hurt or change the ways UAs work at the moment.
>>
>>> Also you should make sure the tests are aligned between the icon
>>> element and
>>> the content element. There does not seem to be such test with the
>>> content
>>> element. If you make such test, you should also align the spec in the
>>> same
>>> manner.
>>
>> I'm not sure I understand, can you design the test to show what you
>> mean. I can then add it to the test suite.
> I meant that there is test like:
> <widget xmlns="http://www.w3.org/ns/widgets">
> <icon src=""/>
> </widget>
>
> but no test like:
> <widget xmlns="http://www.w3.org/ns/widgets">
> <content src="" />
> </widget>
>

I've added a test for this too:

test-suite/test-cases/ta-LTUJGJFCOU/002/gb.wgt (empty src)
Received on Friday, 27 November 2009 13:02:59 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:35 GMT