W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2009

Re: ISSUE-99 (listen): Add shorter method names for addEventListener, et al? [DOM3 Events]

From: Sergey Ilinsky <castonet@yahoo.co.uk>
Date: Fri, 28 Aug 2009 09:39:48 +0000 (GMT)
Message-ID: <810970.61706.qm@web24401.mail.ird.yahoo.com>
To: Robin Berjon <robin@berjon.com>
Cc: Web Applications Working Group WG <public-webapps@w3.org>
> > Starting shortening member names can open the Pandora
> box. What about getElementsByTagName, querySelector etc.? I
> think at this point of time it is better to avoid such an
> initiative.
> Because? 

> And why at this point in time? 
To my knowledge the group is trying to advance the DOM-Events specification to the next level of acceptance.

> Will it become okay next week?
I am not right person to be asked this question.

> We collectively made some pretty bad naming decisions in
> the past, fixing them is both harmless and useful.
Yes, an example of the recent "bad naming decision": querySelectorAll?

Robin, I think proper naming as well as good API design indeed are highly important to the developer productivity. The length of the name to be typed in - hardly.


Received on Friday, 28 August 2009 09:40:31 UTC

This archive was generated by hypermail 2.3.1 : Friday, 27 October 2017 07:26:18 UTC