W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2009

Re: [Window/View Modes] Naming + Feature vs. Query: suggested changes

From: Marcos Caceres <marcosc@opera.com>
Date: Tue, 18 Aug 2009 14:06:36 +0200
Message-ID: <b21a10670908180506p380cc15bo9eba64e4e3cdc2eb@mail.gmail.com>
To: Marcin Hanclik <Marcin.Hanclik@access-company.com>
Cc: "public-webapps@w3.org" <public-webapps@w3.org>
On Tue, Aug 18, 2009 at 1:27 PM, Marcin
Hanclik<Marcin.Hanclik@access-company.com> wrote:
> Hi Marcos,
>
> Thanks for your comments.
>
>>>Can we just call it "view-mode"?
>>>Again, just "viewMode"
> Actually I was thinking about it and got stick to the widget environment with view modes due to the following:
> if the spec would be generic for "any" view modes, then "view-mode" and "viewMode" would be ok. But since we remain in the context of widgets (family and title of the spec) I kept the "widget" prefix. If someone in future would use similar mechanisms with e.g. "application", she/he would use "application-view-mode" etc.
>
> To clarify your position finally:
> should this:
>
>> interface WidgetViewModeChangeEvent : Event {
>>  readonly attribute DOMString widgetViewMode;
>> ...
>> };
>
> be changed to
>
>> interface ViewModeChangeEvent : Event {
>>  readonly attribute DOMString viewMode;
>> ...
>> };
>
> (it is about the name of the interface) ??
>
> Do we care about "non-widgets" using view modes?

Of course not :)  The technology should be generally applicable where possible.

Lets not repeat the same mistakes we made with P&C (namely calling the
widget element "widget" instead of something more generic, like
"package")

-- 
Marcos Caceres
http://datadriven.com.au
Received on Tuesday, 18 August 2009 12:07:36 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:33 GMT