W3C home > Mailing lists > Public > public-webapps@w3.org > January to March 2009

Re: [selectors-api] LCWD comments

From: Krzysztof Maczyński <1981km@gmail.com>
Date: Fri, 30 Jan 2009 21:12:29 +0100
Message-ID: <5C3FE2B06DC9487ABE97F23379E1AA11@kmPC>
To: "Lachlan Hunt" <lachlan.hunt@lachy.id.au>
Cc: <public-webapps@w3.org>

Lachlan,

Thanks for replying quickly; I'll do the same, since it probably matters much more to you, process-wise.

> I have changed it to the 
> plural "node’s subtrees".  Is that acceptable?
Yes, perfectly. But this still isn't formally applicable in all cases:
> The term document order means a depth-first pre-order traversal of the DOM tree or subtree in question.
Would you consider "document tree" (the whole tree, of which when only some part, not necessarily forming a tree, is considered, it inherits the ordering implicitly) instead of "DOM tree or subtree in question"?

> Because the use cases have no need for the method to be able to return 
> the element itself, and as your example shows, doing so would be 
> pointless and confusing.
OK, use cases have their say of course.

>>> definitions of the querySelector methods
>>  
>> Is the plural intended?
> 
> Yes, there are two definitions. One for querySelector() and another for 
> querySelectorAll().
Be sure I didn't miss it and had this very detail on my mind: querySelectorAll by some tacit and in my opinion undesirable assumption becomes one of "the querySelector methods". I suggest a slight change to "NodeSelector methods", referring to the name of the interface, or simply "these two methods".

Best regards,

Chris
Received on Friday, 30 January 2009 20:30:43 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:29 GMT