W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2009

Re: review of A&E

From: Max Froumentin <maxfro@opera.com>
Date: Mon, 04 May 2009 11:20:44 +0200
To: marcosc@opera.com
Cc: public-webapps <public-webapps@w3.org>
Message-ID: <m2prep5imr.fsf@pc214.sm.oslo.opera.com>
I'm satisfied with the resolutions below.
Max.


Marcos Caceres <marcosc@opera.com> writes:

> On Thu, Apr 23, 2009 at 2:04 PM, Max Froumentin <maxfro@opera.com> wrote:
>> Hi Marcos,
>>
>> All changes approved, except the 2 below:
>>
>> Marcos Caceres <marcosc@opera.com> writes:
>>
>>>> 5. [Dependencies on Other Specifications] The last 2 statements logically yield "A user agent MUST attempt to implement [some specifications]"
>>>>
>>> now reads:
>>> [[
>>> A user agent supports a specification if it attempts to implement that
>>> specification.
>>>
>>> A user agent MUST support:
>>>  * the [Widgets-Packaging] specification,
>>>  * the [WebStorage] specification's Storage interface, with the
>>> exclusion of the Database interface.
>>>  * the [DOM3Core] specification.
>>> ]]
>>
>> It ends up to the same logical conclusion, no? If you substitute "support" in the second sentence you get:
>> "A user agent MUST attempt to implement: ....". Surely, 'attempt to' is extra, no?
>
> Ok. I guess it it MUST support then it is expect to be a complete
> implementation.
>
>>>> 14. [The authorName Attribute] This is a comment on P&C: <author> is used to deduce the  "author name" property, but in the definition of <author> it's not specified that the element must contain the author's name.
>>>>
>>>
>>> You can't check that, it's not testable.
>>
>> In fact, I'm saying that the property should be called "author information", rather than "author name".
>
> Right. changed it to widget.authorInfo
Received on Monday, 4 May 2009 09:21:26 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:31 GMT