W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2009

Re: New Widgets A&E Editors Draft

From: Marcos Caceres <marcosc@opera.com>
Date: Fri, 1 May 2009 17:18:15 +0200
Message-ID: <b21a10670905010818t32e63375l9ae1301af50afb1@mail.gmail.com>
To: "Hillebrand, Rainer" <Rainer.Hillebrand@t-mobile.net>
Cc: Arve Bersvendsen <arveb@opera.com>, public-webapps@w3.org
Hi Rainer,
On Fri, Apr 24, 2009 at 4:18 PM, Hillebrand, Rainer
<Rainer.Hillebrand@t-mobile.net> wrote:
> Dear Arve,
>
> Here are my comments on your Widgets A&E last editor's draft.
>
> 1. Change "A environment in which a Widget interface is presented to the user." to "An environment in which a Widget interface is presented to the user."
>

Fixed.

> 2. All URLs in the "Step 8" hyperlinks in section "The Widget Interface" have a backslash at the end.
>

fixed.

> 3. Section "The Widget Interface", definitions of "viewMode" to "version" attributes: e.g. "Upon instantiation, this attribute MUST be set to the value of widget window mode, which is derived from the configuration defaults from processing the configuration document in the [Widgets-Packaging] specification (Step 8)." In step 3 of [Widgets-Packaging], a user agent must assume the defined default values. In step 7, the configuration document is processed. So, "Step 8" seems to be the wrong step. According to my understanding, when a widget uses the Widget interface, step 3 and step 7 were already processed. This means the return value is either the default value or the value that was set in the configuration document. Isn't it the case for all readonly attributes? Only the definition of the identifier attribute contains the "if one was used in the configuration document" condition. What would you think about a definition like "The identifier attribute represents the value of widget element's id attribute, if one was used in the configuration document ([Widgets-Packaging], Step 7). Otherwise, this attribute MUST be set to the value of widget id, which is derived from the configuration defaults from processing the widget resource in the [Widgets-Packaging] specification (Step 3)." which could be easily reused for the other readonly attribute definitions?
>

Yeah, that works for me. I've added your text as en editor's note in
the spec. I will go through and make those changes globally this week.
 I'll email you as soon as their done so you can check I've done it
correctly.

> 4. Section "The Widget Interface": "The authorName attribute represents the name of the person who authored the widget." According to the current P&C, an "author element represents people or an organization attributed with the creation of the widget." So, authorName will not always contain the widget's author name. It could also be the name of an organisation or a company. I would like to propose changing "The authorName attribute represents the name of the person who authored the widget." to "The authorName attribute represents people or an organization attributed with the creation of the widget."
>

Ok, used your text. I also changed the name of this attribute to
"authorInfo" (Max Froumentin argued that it would be more
appropriate).

> 5. Section "The Widget Interface": Change "[...] configuration document as specified in [Widgets]." to "[...] configuration document as specified in [Widgets-Packaging]."
>

Fixed

> 6. Section "The Widget Interface": Change "The onmodechange attribute MAY hold a a function that is [...]" to "The onmodechange attribute MAY hold a function that is [...]".
>

Fixed.

> 7. Section "The onmodechange Callback": This section contains the term "currentMode" two times. However, this attribute is not defined. It can't be "viewMode" because viewMode is either the default value from P&C Step 3 or the value from P&C Step 7.
>

Right, I marked this an issue for now as the whole section needs a
rewrite! The value is actually computed based on the view mode as
determined by the UA.

-- 
Marcos Caceres
http://datadriven.com.au
Received on Friday, 1 May 2009 15:19:12 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:31 GMT