W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2008

Comments on some Web IDL extended attribute names

From: Maciej Stachowiak <mjs@apple.com>
Date: Thu, 02 Oct 2008 20:40:26 -0700
To: "public-webapps@w3.org Group WG" <public-webapps@w3.org>
Message-id: <FF8AE5D6-00B7-43CD-A69E-DA59EFBE751D@apple.com>

I think [NativeObject] should be renamed to [Callback]. It is meant to  
be used for callback objects that have a single designated callback  
method, right?

I think [Variadic] should be renamed [Optional]. A function may be  
variadic, but a parameter is optional, and this goes on the parameter.

Received on Friday, 3 October 2008 03:41:09 UTC

This archive was generated by hypermail 2.3.1 : Friday, 27 October 2017 07:26:12 UTC