public-webapps-github@w3.org from November 2020 by subject

[heycam/webidl] Add bigint type (#525)

[heycam/webidl] Drop stringifier operation longhand (#941)

[heycam/webidl] Help specifying WebAssembly.Function (#937)

[heycam/webidl] Ident underscore escape confusion (#939)

[heycam/webidl] Meet at or around TPAC? (#931)

[heycam/webidl] Migrate to GitHub Actions (#935)

[heycam/webidl] Normative: Add `BigInt64Array` and `BigUint64Array` (#936)

[heycam/webidl] ObservableArray and Namespace (#942)

[heycam/webidl] Proposal: DOMException.ignoreAborts(promise) (#933)

[heycam/webidl] Specify that dictionaries can't be the type of attr/constant (#940)

[heycam/webidl] Why are dictionaries disallowed for attribute types? (#938)

[w3c/clipboard-apis] Getting file/image from clipboard (#134)

[w3c/clipboard-apis] Make it possible to read image/svg+xml from the clipboard (#92)

[w3c/clipboard-apis] TPAC planning and specification status report (#124)

[w3c/clipboard-apis] What does ClipboardItem.getType do (#119)

[w3c/editing] Should parts of Input Events level 2 be moved to level 1? (#275)

[w3c/editing] Update README.md (#274)

[w3c/FileAPI] Support using AbortController with FileAPI (#159)

[w3c/gamepad] adding multitouch extension (#142)

[w3c/IndexedDB] Combining cursors / query execution engine (#298)

[w3c/manifest] "Authority of manifest" section is wrong (#888)

[w3c/manifest] Adding field `display_override` to the manifest (#932)

[w3c/manifest] Documentation on choosing between "equally appropriate" icons does not match the provided example (#940)

[w3c/manifest] Editorial: clarify where to get apps name from (#927)

[w3c/manifest] Editorial: Move some members to App Information Note (#924)

[w3c/manifest] How could I participate and create an alwaysOnTop flag? (#938)

[w3c/manifest] Install button on another domain (#726)

[w3c/manifest] Processing the manifest is no longer a function of document URL (#834)

[w3c/manifest] Spec Metadata Lists Incorrect Values for Chrome (#939)

[w3c/permissions] [question] permission scope (#226)

[w3c/permissions] Media autoplay permission (#150)

[w3c/permissions] PWA install permission (#227)

[w3c/permissions] Use media device permission revocation algorithm. (#225)

[w3c/pointerlock] Add lock options to requestPointerLock (#49)

[w3c/push-api] How do I authenticate a user (#314)

[w3c/push-api] userVisibleOnly should be standardized to match browser behaviour (#313)

[w3c/selection-api] Remove outdated note about getSelection() (#128)

[w3c/ServiceWorker] "no-cors" CSS SOP violation (#719)

[w3c/ServiceWorker] `Vary` and requests added after the SW (#1542)

[w3c/ServiceWorker] Clarify dynamic-imported scripts are never installed (#1356)

[w3c/ServiceWorker] clients.claim() with a blob URL worker (#1554)

[w3c/ServiceWorker] consider allowing a non-scope identifier for registrations (#1512)

[w3c/ServiceWorker] Detecting service worker termination (#1550)

[w3c/ServiceWorker] Expose GeoLocation to workers (#745)

[w3c/ServiceWorker] get importScripts to work offline (#1555)

[w3c/ServiceWorker] Handle asynchronous modules (top-level await). (#1444)

[w3c/ServiceWorker] Service worker & Blocked cookies (#1551)

[w3c/ServiceWorker] ServiceWorkerContainer: Web Workers and Service Workers (#1552)

[w3c/ServiceWorker] unable to open https://wicg.github.io/cookie-store/ (#1547)

[w3c/ServiceWorker] Virtual call on November 20, 2020 (#1553)

[w3c/ServiceWorker] Virtual calls around TPAC time (#1536)

[w3c/touch-events] Specify what browsers do on non-touch devices (#64)

[w3c/uievents] Composition events lack on* attribute counterparts (#280)

[w3c/uievents] Document the cancelability of wheel events (#282)

[w3c/uievents] Expose 'inertial scrolling state' in wheel events (#58)

[w3c/uievents] mousemove and preventDefault() (#278)

[w3c/uievents] We don't have a definition for "contextmenu" event (#279)

[w3c/uievents] What's the rationale for the currently specified interaction between dead keys and `KeyboardEvent.key`? (#281)

[w3c/webcomponents] Custom 'void' or self-closing elements (HTML parser changes) (#624)

[w3ctag/design-reviews] Adding AbortSignal option to addEventListener (#569)

[w3ctag/design-reviews] Blink Shipping Process (#516)

[w3ctag/design-reviews] Byte Streams (#567)

[w3ctag/design-reviews] CAPTCHAs are horrible (#558)

[w3ctag/design-reviews] CORS-RFC1918 (#572)

[w3ctag/design-reviews] CSS Color: lab(), lch() (#488)

[w3ctag/design-reviews] Digital Goods API (#571)

[w3ctag/design-reviews] DOM Review Draft — Published 15 June 2020 (#573)

[w3ctag/design-reviews] Feature Policy: Document Policies (#408)

[w3ctag/design-reviews] Font Enumeration API (#399)

[w3ctag/design-reviews] HR review of IMSC 1.2 FPWD (#474)

[w3ctag/design-reviews] making the "total" field optional in PaymentRequest API (#512)

[w3ctag/design-reviews] Media Source Extensions for WebCodecs (#576)

[w3ctag/design-reviews] MiniApp Lifecycle (#523)

[w3ctag/design-reviews] MiniApp Manifest (#524)

[w3ctag/design-reviews] MiniApp URI Scheme (#478)

[w3ctag/design-reviews] Personalization Semantics Explainer and  Module 1 (#476)

[w3ctag/design-reviews] Realms API ECMAScript Proposal (#542)

[w3ctag/design-reviews] Require embedees to opt-in. (#578)

[w3ctag/design-reviews] Review of CSS Sizing 3 (#565)

[w3ctag/design-reviews] Review of NativeIO (#566)

[w3ctag/design-reviews] Screen Fold API (#575)

[w3ctag/design-reviews] Scroll To Text (#392)

[w3ctag/design-reviews] Serial API (#431)

[w3ctag/design-reviews] Storage Buckets API (#562)

[w3ctag/design-reviews] Temporal proposal (#311)

[w3ctag/design-reviews] User Idle Detection (#336)

[w3ctag/design-reviews] VirtualKeyboard API - show/hide policy (#498)

[w3ctag/design-reviews] Web Authentication Level 2 (#577)

[w3ctag/design-reviews] Web Neural Network API (#570)

[w3ctag/design-reviews] WebHID API (Human Interface Device) (#370)

[w3ctag/design-reviews] WebRTC Priority Control API (#560)

[w3ctag/design-reviews] WebXR Anchors Module (#479)

[w3ctag/design-reviews] WebXR Hand Input API Specification (#568)

[w3ctag/design-reviews] WebXR Layers (#528)

[w3ctag/design-reviews] WebXR Lighting Estimation (#574)

[whatwg/dom] [Declarative Shadow DOM] How should we build the "opt-in" for fragment parsing of declarative Shadow DOM? (#912)

[whatwg/dom] AbortController, AbortSignal, and garbage collection (#920)

[whatwg/dom] Add declarative Shadow DOM features (#892)

[whatwg/dom] Add Imperative Slot API (#860)

[whatwg/dom] Add NodeList.setAttributes (#895)

[whatwg/dom] add signal to addEventListener (#919)

[whatwg/dom] Adoption and DocumentFragment, part two (#819)

[whatwg/dom] Another interop problem with capturing/bubbling (#926)

[whatwg/dom] concept-range-bp-set should compare root nodes before bp relative position (#924)

[whatwg/dom] Consider adding AbortController.prototype.follow(signal) (#920)

[whatwg/dom] Correct step in matches() (#923)

[whatwg/dom] Declarative Shadow DOM (#831)

[whatwg/dom] Element.matches(selectors) seeming typo / missing step (#921)

[whatwg/dom] Encourage use of AbortError for cancellation? (#927)

[whatwg/dom] Fix the comparing boundary points of `concept-range-bp-set` (#925)

[whatwg/dom] Need to catch exceptions to report them (#889)

[whatwg/dom] NodeIterator's pre-removing steps does not match browsers (#907)

[whatwg/dom] Proposal - Update XPath to (at least) v2.0 (#903)

[whatwg/dom] Remove Goals and Historical sections (#918)

[whatwg/dom] Removing event listeners through an identifier (#208)

[whatwg/dom] Should event.stopPropagation() during capturing prevent the bubbling phase? (#916)

[whatwg/dom] Suggestion: introduce window.beforeunloadwarning, deprecate window.onbeforeunload (#929)

[whatwg/dom] Support `AbortSignal`s in `addEventListener`s options to unsubscribe from events? (#911)

[whatwg/dom] U (#915)

[whatwg/dom] Ueue (#914)

[whatwg/dom] What is the "security policy" for adding new events and elements to the Web Platform? (#913)

[whatwg/dom] What should `adoptNode` return for a `DocumentFragment` with a non-null host? (#930)

[whatwg/dom] When cloning a custom element, `element.outerHTML !== element.cloneNode().outerHTML` appears (#922)

[whatwg/dom] Why does `preventDefault()` in `pointer` events break `mouse` events? (#917)

[whatwg/dom] Why does `preventDefault()` in pointer events break mouse events? (#917)

[whatwg/encoding] Add NeXTSTEP encoding (#248)

[whatwg/encoding] Consider adding TextEncoder.containsLoneSurrogates() static (#174)

[whatwg/encoding] Editorial: consider another name for the run algorithm (#245)

[whatwg/encoding] Editorial: rename internal run algorithm (#246)

[whatwg/encoding] Editorial: revamp the way we deal with code points and bytes (#247)

[whatwg/fetch] 204 and json (#113)

[whatwg/fetch] [editorial] Link to `Content Security Policy objects` is broken (#1110)

[whatwg/fetch] Add port 5060 to bad ports (SIP) (#1108)

[whatwg/fetch] Add port 5060, 5061 to blocked port list - fixes #1108 (#1109)

[whatwg/fetch] bug (#1114)

[whatwg/fetch] Create thjenhao1992bb (#1119)

[whatwg/fetch] Document bad port blocking rationale (#956)

[whatwg/fetch] Document how new protocols relate to port blocking (#1106)

[whatwg/fetch] Editorial: align bad port service names with IANA (#1107)

[whatwg/fetch] Editorial: Fix CORS legal and illegal combinations table (#1115)

[whatwg/fetch] Enforce CORP on "navigate" request mode (#1113)

[whatwg/fetch] FetchObserver (for a single fetch) (#607)

[whatwg/fetch] Incorperate let-localhost-be-localhost (#1118)

[whatwg/fetch] Meta: integrate better with CSP (#1111)

[whatwg/fetch] Observer API for fetch groups (#65)

[whatwg/fetch] Point default referrer policy to a constant defined in RP spec (#1066)

[whatwg/fetch] Port blocking: "Typical service" (#750)

[whatwg/fetch] Proposal: Allow servers to take full responsibility for cross-origin access protection (#878)

[whatwg/fetch] Should 0.0.0.0 always be a network error? (#1117)

[whatwg/fetch] Wg (#1116)

[whatwg/fetch] Why doesn't `fetch` reject if 400 ≤ status < 600? (#18)

[whatwg/fetch] Ya (#1112)

[whatwg/storage] Brave Bat Compact (#116)

[whatwg/streams] A guide for a bidirectional transport? (#1032)

[whatwg/streams] Add URL.createObjectURL(stream) support (#480)

[whatwg/streams] Editorial: Remove redundant steps from AcquireDefaultReader & BYOBReader (#1087)

[whatwg/streams] Is autoAllocateChunkSize permitted to be zero? (#1089)

[whatwg/streams] ReadableStream.from(asyncIterable) (#1083)

[whatwg/streams] ReadableStream.from(X) (#1018)

[whatwg/streams] Update Byte Streams Explainer (#1088)

[whatwg/streams] Using streams from other specs: define a byte-counting strategy (#1085)

[whatwg/streams] Using streams from other specs: explain some best practices for byte streams (#1086)

[whatwg/streams] Using streams from other specs: you can't really use "create" (#1084)

[whatwg/url] File URL reparse bug with percent encoded windows drive letter (#559)

[whatwg/url] IPv4 host parser + site definition seems potentially dangerous. (#560)

[whatwg/url] Percent-encoding of query wrong for ISO-2022-JP (#557)

[whatwg/url] Provide a succinct grammar for valid URL strings (#479)

[whatwg/url] Refactor query state to operate on a buffer (#558)

[whatwg/xhr] Add link to declarative shadow dom opt-in (#300)

[whatwg/xhr] Replace Feature Policy integration with Document Policy (#296)

[whatwg/xhr] Replace Feature Policy integration with Document Policy. (#295)

[whatwg/xhr] Stop censoring responseURL's fragment xiexie (#294)

[whatwg/xhr] Support for referrerPolicy (#297)

[whatwg/xhr] update (#298)

[whatwg/xhr] xmlHtmlrequest (#299)

[WICG/webcomponents] CustomEvents Add Event Handler in Html (#908)

[WICG/webcomponents] define behavior of `@import` in Cascading Style Sheet (CSS) modules (#870)

[WICG/webcomponents] Scoped Custom Element Registry: Moving elements with shadow roots between documents (#907)

[WICG/webcomponents] The is="" attribute is confusing? Maybe we should encourage only ES6 class-based extension. (#509)

[WICG/webcomponents] Updating Element Registration. (#820)

Last message date: Monday, 30 November 2020 22:36:06 UTC