public-webapps-github@w3.org from August 2020 by subject

[heycam/webidl] add a type to represent the undefined value (#60)

[heycam/webidl] Ask for Reffy issues from breaking changes (#907)

[heycam/webidl] Consider a pattern for dictionary arguments which must have at least one member (#903)

[heycam/webidl] Consolidate issue tracking links in the header under "Feedback" (#169) (13372c2)

[heycam/webidl] Enums that does not throw? (#893)

[heycam/webidl] Getting rid of optional (#905)

[heycam/webidl] Intent to use Constants (#911)

[heycam/webidl] Propagate active script to callbacks (#902)

[heycam/webidl] record<> converted to a JS value should use a null prototype (#904)

[heycam/webidl] Should EnforceRange be allowed on consts and return types? (#842)

[heycam/webidl] Syntatictic way to mark as historical/deprecated (#910)

[heycam/webidl] void -> undefined, and allow it anywhere. (#906)

[heycam/webidl] void -> undefined, and allow it anywhere. https://github.com/heycam/w… (#906)

[w3c/clipboard-apis] Consider renaming master branch (#131)

[w3c/clipboard-apis] Editorial: Align with Web IDL specification (#133)

[w3c/clipboard-apis] Remove clipboard-read permission (#132)

[w3c/DOM-Parsing] Editorial: Align with Web IDL specification (#64)

[w3c/DOM-Parsing] insertAdjacentHTML should return a NodeList (#63)

[w3c/editing] Add a way to query for the list of enabled commands in contenteditabledisabled spec (#272)

[w3c/editing] EditContext: Can we create an EditContext label to help with issue tracking? (#270)

[w3c/editing] EditContext: Change "focus" to "activate" to avoid confusion with the focus in the activeElement (#269)

[w3c/editing] EditContext: Rename updatelayout into something more intuitive (#267)

[w3c/editing] EditContext: Who's going to handle caret navigation? (#266)

[w3c/editing] execCommand("indent") conflicts with the content model of <ul>/<ol> (#256)

[w3c/editing] fix(execCommand): map outdent to formatOutdent (#259)

[w3c/editing] March 13th, 2020 Editing TF call (#237)

[w3c/editing] Rename EditContext.focus/blur to activate/deactivate. (#271)

[w3c/editing] Rename updateLayout to updateBounds. (#268)

[w3c/editing] spellchecking - how to give JS devs more control (#166)

[w3c/editing] Update to a spec draft document (#251)

[w3c/editing] updating spec draft (#265)

[w3c/FileAPI] Async factory methods for Blob and File (#157)

[w3c/FileAPI] Blob URL store partitioning (#153)

[w3c/FileAPI] Editorial: Align with Web IDL specification (#158)

[w3c/FileAPI] Store HTTPS state on Blob objects (#35)

[w3c/gamepad] Consider how to support devices like Apple Remote (#139)

[w3c/gamepad] Mapping of HID Events to the Gamepad API (#56)

[w3c/gamepad] Vibrate feature for Gamepad (#19)

[w3c/IndexedDB] `getAll()` with both key and value (or index key and primary key) (#206)

[w3c/IndexedDB] Editorial: Align with Web IDL specification (#345)

[w3c/IndexedDB] Encrypted storage (#191)

[w3c/manifest] Add a unique identifier for a PWA (#586)

[w3c/manifest] Adding field `display_override` to the manifest (#932)

[w3c/manifest] Editorial: clarify when/how 'auto' is applied (#926)

[w3c/manifest] Fix related_applications parsing instructions (#933)

[w3c/manifest] Privacy Review: handle start_url tracking (#399)

[w3c/manifest] Provide guidance to UAs on appropriate names for "platform" members (#862)

[w3c/manifest] Related applications members (at risk?) (#877)

[w3c/manifest] Shortcuts: Dynamic update or JS access to URLs (#867)

[w3c/manifest] TPAC planning and specification status report (#906)

[w3c/permissions] Clipboard permissions (#175)

[w3c/permissions] It is unclear which of PermissionStatus change event or MediaStreamTrack ended event should fire first in case Permission is revoked (#223)

[w3c/pointerlock] Add lock options to requestPointerLock (#49)

[w3c/pointerlock] Editorial: Align with Web IDL specification (#66)

[w3c/pointerlock] Option needed to disable OS-level adjustment for mouse acceleration (#36)

[w3c/screen-orientation] Editorial: Align with Web IDL specification (#200)

[w3c/selection-api] Editorial: Align with Web IDL specification (#123)

[w3c/selection-api] Selection events for text controls (#53)

[w3c/ServiceWorker] `<iframe sandbox />` + SW (#1390)

[w3c/ServiceWorker] Add 'immediate: true' to the draft spec (#1489)

[w3c/ServiceWorker] Add `ServiceWorkerRegistration.id` and supporting algorithm changes. (Fixes #1512) (#1526)

[w3c/ServiceWorker] Allow Caching of POST requests (#977)

[w3c/ServiceWorker] allow service workers to created nested dedicated workers (#1529)

[w3c/ServiceWorker] cache.match should create partial responses if given a range request (#913)

[w3c/ServiceWorker] consider allowing a non-scope identifier for registrations (#1512)

[w3c/ServiceWorker] Define Purge Service Worker Registrations (#1506)

[w3c/ServiceWorker] DO NOT MERGE - Add id to ServiceWorkerRegistration. (Fixes #1512) (#1526)

[w3c/ServiceWorker] Editorial: Align with Web IDL specification (#1530)

[w3c/ServiceWorker] Editorial: update to modern Web IDL conventions (#1528)

[w3c/ServiceWorker] Give the empty destination to the CORP check (#1531)

[w3c/ServiceWorker] Is it possible to serve service workers from CDN/remote origin? (#940)

[w3c/ServiceWorker] Override the "mode" of Service Worker requests (#1534)

[w3c/ServiceWorker] Proposal: clientURL property on FetchEvent (#1532)

[w3c/ServiceWorker] register() lacks same origin check (#1518)

[w3c/ServiceWorker] should sec-ch-ua headers be visible in FetchEvent.request.headers (#1525)

[w3c/ServiceWorker] Update environment settings object creation (#1527)

[w3c/ServiceWorker] Use new Streams algorithms (#1533)

[w3c/ServiceWorker] What to do when an installed service worker's certificate changes/expires (#1523)

[w3c/uievents] 9.4 mutation events are deprecated (#102)

[w3c/uievents] Add an accessibility section (#263)

[w3c/uievents] Define events directly caused by user interaction (#270)

[w3c/uievents] Event order between "keypress" and "beforeinput" (#220)

[w3c/uievents] Fire an event on caret position change (#111)

[w3c/uievents] Giving JavaScript ability to toggle the state of the modifier keys (#274)

[w3c/uievents] IDL for legacy dictionary members are not parsed as IDL (#271)

[w3c/uievents] Insert Key is not part of the spec as a modifier key (#273)

[w3c/uievents] Mark the legacy dictionary members as IDL (#272)

[w3c/uievents] Need clarification how mouseenter/leave should behave while modifying DOM tree during event dispatch (#244)

[w3c/uievents] Need procedural algorithms for all events (#200)

[w3c/uievents] Should DOM be modified before or after compositionupdate? edge/IE do one thing, chrome/saf/firefox do another? (#66)

[w3c/uievents] Should require Input event to be fired within same event loop as keydown? keypress? neither? (#238)

[w3c/uievents] Update focusin/focusout event order to match implementations? (#276)

[w3c/uievents] Upstream InputEvent (#275)

[w3c/webcomponents] 2020 Virtual F2F for Accessibility and Web Components (#872)

[w3c/webcomponents] ::slotted() should full support complex selector!! (#745)

[w3c/webcomponents] [idea] shadowattach event (#893)

[w3c/webcomponents] Add Scoped CustomElementRegsitry explainer (#865)

[w3c/webcomponents] Allowing CSS combinators postfixed to the ::slotted() selector (#889)

[w3c/webcomponents] CustomElementRegistry.prototype.define<bulk>() (#892)

[w3c/webcomponents] deleted (#890)

[w3c/webcomponents] Expose shadowRoot on element internals (#871)

[w3c/webcomponents] idea: Allow light DOM to delegate styles/behavior to shadow DOM (#883)

[w3c/webcomponents] Meet at TPAC this autumn? (#877)

[w3c/webcomponents] Scoped Custom Element Registries (#716)

[w3c/webcomponents] Style ::slotted children (#594)

[w3ctag/design-reviews] [TAG review request] PWAs as URL Handlers (#552)

[w3ctag/design-reviews] Blink Shipping Process (#516)

[w3ctag/design-reviews] Client Hint Reliability mechanisms (#549)

[w3ctag/design-reviews] Client-side video editing (MediaBlob) (#514)

[w3ctag/design-reviews] Constant bitrate audio encoding with MediaRecorder (#540)

[w3ctag/design-reviews] CSS color-mix function (#526)

[w3ctag/design-reviews] hasDroppedEntry in PerformanceObserverCallback (#547)

[w3ctag/design-reviews] Import Conditions (#535)

[w3ctag/design-reviews] IndexedDB putAll (#536)

[w3ctag/design-reviews] jxl Content-Encoding (#541)

[w3ctag/design-reviews] Media Feeds API (#477)

[w3ctag/design-reviews] MediaStreamTrack Content Hints (#539)

[w3ctag/design-reviews] Native File System API (#390)

[w3ctag/design-reviews] Navigation to Unsigned Web Bundles (Web Packaging) (#509)

[w3ctag/design-reviews] Partial freezing of the User-Agent string (#467)

[w3ctag/design-reviews] Pen Events API (#553)

[w3ctag/design-reviews] Raw Sockets API (#548)

[w3ctag/design-reviews] Realms API ECMAScript Proposal (#542)

[w3ctag/design-reviews] Referrer handling - default policy and capping (#538)

[w3ctag/design-reviews] Screen Enumeration API (#413)

[w3ctag/design-reviews] Screen Wake Lock API (#543)

[w3ctag/design-reviews] Secure Payment Confirmation (#544)

[w3ctag/design-reviews] Transferable Streams Spec (#551)

[w3ctag/design-reviews] VirtualKeyboard API - show/hide policy (#498)

[w3ctag/design-reviews] Web page settings to save battery (#546)

[w3ctag/design-reviews] Web Share API review (#554)

[w3ctag/design-reviews] WebHID API (Human Interface Device) (#370)

[w3ctag/design-reviews] WebRTC Insertable Streams (#531)

[w3ctag/design-reviews] WebXR Depth API (#550)

[w3ctag/design-reviews] WebXR Device API (#545)

[w3ctag/design-reviews] Window Controls Overlay for Installed Desktop Web Apps (#481)

[whatwg/dom] Add declarative Shadow DOM features (#858)

[whatwg/dom] Add Imperative Slot API (#860)

[whatwg/dom] Add new mutation observer init options elementFilterByAttribute and elementLocalNameFilter (#885)

[whatwg/dom] Add new mutation observer init options elementHasAttributeNameFilter and elementLocalNameFilter (#885)

[whatwg/dom] Add translation of korean (#882)

[whatwg/dom] Adding a return value to `controller.abort()` which represents abort completion (#881)

[whatwg/dom] Declarative Shadow DOM (#831)

[whatwg/dom] Editorial: Align with Web IDL specification (#886)

[whatwg/dom] Editorial: use Infra language for Aborting section (#887)

[whatwg/dom] Meta: update repository files (e191f73)

[whatwg/dom] Proposal: a DocumentFragment whose nodes do not get removed once inserted (#736)

[whatwg/dom] Proposal: Make `DOMTokenList` a writable `setlike` (#884)

[whatwg/dom] Strange behavior with `insertBefore` vs `appendChild` and transitions (#880)

[whatwg/encoding] Concatenating two ISO-2022-JP outputs from a conforming encoder doesn't result in conforming input (#115)

[whatwg/encoding] Differences between tests and specification (#169)

[whatwg/encoding] Encoding utf-8 (#223)

[whatwg/encoding] EUC-JP encoding is currently ambiguous (#225)

[whatwg/encoding] Rename Encoding's "streams" to "I/O queues" (#215)

[whatwg/encoding] Use new Streams algorithm and mixins (#224)

[whatwg/fetch] "get, decode, and split" seems incorrect (#1068)

[whatwg/fetch] 421 and upload streams (#982)

[whatwg/fetch] A new Request(input, init) constructor step sounds weird. (#1061)

[whatwg/fetch] Add `json` to RequestDestination values (#1042)

[whatwg/fetch] Add device-memory and network quality client hints to the list (#725)

[whatwg/fetch] Add examples for collect an HTTP quoted string (#1069)

[whatwg/fetch] Allow a request body to be a byte sequence/string (#1083)

[whatwg/fetch] Allow strings or byte sequences as bodies? (#1073)

[whatwg/fetch] Augment COEP violation report (#1079)

[whatwg/fetch] Blob URLs should grab HTTPS state from Blob objects (#270)

[whatwg/fetch] blob: URLs and range requests (#1070)

[whatwg/fetch] Change the default referrer policy to 'strict-origin-when-cross-origin'. (#952)

[whatwg/fetch] Client Hints infrastructure (#1072)

[whatwg/fetch] Editorial: Align with Web IDL specification (#1078)

[whatwg/fetch] Editorial: Fix sentence fragment about header list (#1086)

[whatwg/fetch] Fetch metadata (#1087)

[whatwg/fetch] Fix typos (#1065)

[whatwg/fetch] Handle blob URLs without a backing blob (#1077)

[whatwg/fetch] Headers API corrections (#833)

[whatwg/fetch] Integrate latest Client Hints updates (#726)

[whatwg/fetch] Meta: disambiguate fetch() from the CSS function with the same name (#1084)

[whatwg/fetch] Next steps for HTTPS state (#1062)

[whatwg/fetch] Partition HTTP Connections (#1063)

[whatwg/fetch] PATCH verb (#50)

[whatwg/fetch] Point default referrer policy to a constant defined in RP spec (#1066)

[whatwg/fetch] Remove HTTPS state concept (#1067)

[whatwg/fetch] Request.headers is shared across Requests. Is it OK? (#1075)

[whatwg/fetch] Set request header's guard if no-cors (#1076)

[whatwg/fetch] The guard of headers created from no-cors (#1074)

[whatwg/fetch] The guard of headers created from no-cors request (#1074)

[whatwg/fetch] TPAC 2020: Fetch Standard meeting interest (#1082)

[whatwg/fetch] Use new Streams algorithms (#1085)

[whatwg/fullscreen] Editorial: Align with Web IDL specification (#183)

[whatwg/fullscreen] Internal iframe fullscreen event missing? (#179)

[whatwg/fullscreen] Meta: update the final reference to Feature Policy (#182)

[whatwg/storage] Editorial: fix typo in 'Model' section (#111)

[whatwg/storage] Review Draft Publication: August 2020 (#112)

[whatwg/storage] TPAC 2020: Storage Standard meeting interest (#113)

[whatwg/streams] Add examples for stopping pipes (#1059)

[whatwg/streams] Add examples of using identity transforms to manipulate streams (#847)

[whatwg/streams] Add section on other stream pairs (7e10304)

[whatwg/streams] Always resolve tee's cancel promise after stream closes or errors (#1039)

[whatwg/streams] can streams be transferred via postMessage()? (#276)

[whatwg/streams] Cancelling one branch of a tee'd stream never finishes if other branch reads all chunks (#1038)

[whatwg/streams] Create a dedicated section for interfacing with other specs (#1073)

[whatwg/streams] Don't error an errored WritableStream on messageerror (#1069)

[whatwg/streams] Editorial: add cross-links to internal slots (#1050)

[whatwg/streams] Editorial: Align with Web IDL specification (#1068)

[whatwg/streams] Editorial: Export [[detached]] slots (#1064)

[whatwg/streams] Editorial: fix extra "the" in controller.error() (#1070)

[whatwg/streams] Editorial: rename internal slots for brevity (#1061)

[whatwg/streams] GenericTransformStream mixin vs. subclassing (#1074)

[whatwg/streams] Make quotes around code font words consistent (#1062)

[whatwg/streams] Remove https://streams.spec.whatwg.org/#ts-constructor step 12 (#1065)

[whatwg/streams] Remove redundant startPromise declaration (#1067)

[whatwg/streams] Remove TransformStream constructor step 12 (#1065)

[whatwg/streams] Review Draft Publication: August 2020 (#1066)

[whatwg/streams] Separate out exported abstract ops from internal ones (#372)

[whatwg/streams] Should we add writableStream.write()? readableStream.read()? (#1072)

[whatwg/streams] Support transferable streams (postMessage) (#1053)

[whatwg/streams] TPAC 2020: Streams Standard meeting interest (#1071)

[whatwg/streams] Transferable streams: the double transfer problem (#1063)

[whatwg/url] Add named validation errors (#514)

[whatwg/url] Add the component percent-encode set (#513)

[whatwg/url] Clarify scope of API define in the spec or split specs (#535)

[whatwg/url] Editorial: Align with Web IDL specification (#534)

[whatwg/url] Feature proposal: eTLD+1 web API (#528)

[whatwg/url] Merhaba bu hackerone JSON api ile ilgili sanırım (#532)

[whatwg/url] Named validation errors (#502)

[whatwg/url] Need an "unreserved" character set (and better define how to percent-encode arbitrary strings) (#369)

[whatwg/url] Non-special URLs were not idempotent (#505)

[whatwg/url] Reparsing problem with non-special URL and double-dot path component (#415)

[whatwg/url] Review Draft Publication: August 2020 (#533)

[whatwg/url] Support relative URLs (#531)

[whatwg/xhr] Editorial: Align with Web IDL specification (#288)

[whatwg/xhr] my GAME DONT OPEN FROM THE HACK IDK WHY PLEASE FIX THIS (#286)

[whatwg/xhr] Non-simple CORS requests on redirect (#255)

[whatwg/xhr] Review Draft Publication: August 2020 (#287)

Last message date: Monday, 31 August 2020 23:42:00 UTC