public-webapps-github@w3.org from June 2015 by subject

[clipboard-apis] Non Recognizable formats (#9)

[clipboard-apis] Should queryCommandEnabled(cut|copy|paste) trigger onbefore* events? (#4)

[clipboard-apis] The ClipboardEvent constructor is strange (#10)

[dom] =Add hint that `event.bubbles` is configurable. (8d1ef8f)

[dom] `document.importNode` and `document.adoptNode` should throw exceptions when acting upon ShadowRoots (#46)

[dom] Add [TreatNullAs=EmptyString] to Attr.nodeValue/textContent (#36)

[dom] Add [TreatNullAs=EmptyString] to Attr.nodeValue/textContent (df9901c)

[dom] Add hint that `event.bubbles` is configurable. (#35)

[dom] Attributes need case-insensitive matching on getting (#41)

[dom] Cleanup "equals" usage (#40)

[dom] Fix the ID for DOMImplementation (was #interface=domimplementation) (27b9b3c)

[dom] Less ambiguous step description for Node.before (#47)

[dom] matches, querySelector, etc. shouldn't throw on an unrecognized selector (#39)

[dom] Proposal: Node#appendSibling/prependSibling (#38)

[dom] Question about references after Bikeshed conversion (#42)

[dom] Remove unnecessary conditions from the 'traverse children' algorithm. (#45)

[dom] Rename replace() to replaceWith() (b7563aa)

[dom] Rewrite replaceWith/before/after algorithms (#32)

[dom] setAttribute() needs to lowercase for HTML nodes in HTML documents. Fixes #31 (afe5b5e)

[dom] Shorter setAttribute() method (#43)

[dom] The mutation method macro has undefined behavior when nodes is empty (#44)

[editing] ContentEditable with UserSelect=None needs to be documented (#20)

[editing] How do we switch the caret between overtype and insert mode? (#55)

[editing] Should Device-Specific Input Events say what Responsive Input Event they will cause? (#25)

[editing] Should the caret move by default, and should we define this behavior? (#58)

[editing] spell checking should be able to span multiple Typing Nodes (#50)

[editing] What browser internals can be exposed to help us move the caret in (and against) the block direction? (#56)

[editing] What caret positions do we need to allow? (#51)

[editing] What to do with contentEditableTrue? (#54)

[editing] What to do with execCommand? (#53)

[editing] What to do with IME input when typing over a large selection? (#59)

[encoding] Benefits of "Legacy" Encodings – Byte Counter (#4)

[encoding] Big5 decoder fails to prepend ASCII byte when pointer is non-null but code point is null (#5)

[encoding] Closes issue 5: Test _code point_ instead of _pointer_ for null when prepending ASCII byte. (#6)

[fetch] [Question] Is there any suggested way to tell if we are dealing with a fetch request server-side? (#58)

[fetch] Abort fetch upon document unload (#53)

[fetch] Aborting a fetch (#27)

[fetch] Add support for federated token binding to fetch (#30)

[fetch] Allow "manual" redirect fetches with caveats (#66)

[fetch] Document usage for GET requests with URI parameters (#56)

[fetch] HTTP/2 server push support (#51)

[fetch] Mechanism to indicate "destination context" (#64)

[fetch] Moar hyphens (#63)

[fetch] Observer API for fetch registry (#65)

[fetch] POST calls - Request Payload is not shown with native fetch (#59)

[fetch] Proposed backward-incompatible change: requiring cloning all requests/responses (#61)

[fetch] Regarding "switch on response's status" (#60)

[fetch] Rename `response` in HTTP fetch 3.1.1-2 (#54)

[fetch] Request constructor does not check used flag on null body (#55)

[fetch] Response content-length header almost always wrong (#67)

[fetch] Tests (#62)

[fetch] Why doesn't `fetch` reject if 400 ≤ status < 600? (#18)

[fetch] worker request context definition references undefined "serviceworker" context (#68)

[FileAPI] Blob.close() has several problems (#10)

[FileAPI] Controlling Blob URL's (#8)

[FileAPI] Don't use [EnsureUTF16] (gone from Web IDL) (#9)

[FileAPI] Stop using DOMError (#11)

[filesystem-api] fixing typo (#5)

[filesystem-api] Observable is not appropriate for directory listing; async iterable would be better (#4)

[IndexedDB] Add getKey to IDBObjectStore (#26)

[IndexedDB] Add link to IDB Feature Request wiki (#25)

[IndexedDB] Add openCursor(key, primaryKey) and continuePrimaryKey (#14)

[IndexedDB] For schema mutations, should InvalidStateError trump TransactionInactiveError? (#23)

[IndexedDB] Introduce IDBKeySet (#19)

[IndexedDB] Make IDBFactory.cmp [ImplicitThis] (#24)

[IndexedDB] Validate exception ordering against implementations (#11)

[manifest] .json in MIME registration is causing problems. (#381)

[manifest] A means to control how long a splash screen should remain on screen. (#372)

[manifest] Address timeless' review comments (#383)

[manifest] camelCase more suitable to JSON and JS API (#72)

[manifest] Drop .json as standard file ext. (closes #381) (#382)

[manifest] Manifest format should support some way of including a splash screen (#9)

[manifest] What's the use case for theme_color? (#356)

[permissions] Add "fullscreen" (#26)

[permissions] Add permissions.request() (#41)

[permissions] Add permissions.revoke() (#40)

[permissions] Add persistent storage (#39)

[permissions] Add Promise.all() example for multiple queries (#19)

[permissions] Added Editor IDs (#37)

[permissions] Barebone definition of permissions.revoke(). (63951c2)

[permissions] Extensibility: make sure we have it right (#17)

[permissions] Geolocation API does not leave the page unaware of permission status (#30)

[permissions] grammar nits (#38)

[permissions] Move to using Echidna (#24)

[permissions] Privacy Considerations (#22)

[permissions] Remove global variables (#35)

[permissions] Remove object-based permissions (#42)

[permissions] Rename PermissionStatus.status to PermissionStatus.state (#31)

[permissions] Should we have a more explicit enumerating process? (#13)

[permissions] status of this document: reached FPWD (#36)

[permissions] Tackle origin (#34)

[permissions] What should "retrieve the permission state" do for pickers? (#8)

[permissions] Why "prompt" instead of "default"? (#25)

[push-api] How to implement the retry send notification if the confirmation for notification send is missing in API documentation (#151)

[push-api] Straw man for encryption (#130)

[screen-orientation] "Whenever a top-level browsing context is navigated, the user agent MUST lock the orientation of the document to the document's default orientation. " doesn't deal with fragment navigation (#87)

[screen-orientation] Clarify the meaning of "screen orientation angle" (#85)

[screen-orientation] Deal with fragment navigation (#87)

[screen-orientation] Use current orientation angle instead of screen orientation angle in normative text. (#86)

[selection-api] Define the interaction with user-select CSS property (#46)

[selection-api] Expand selectstart to cover use cases for contenteditable=typing (#45)

[selection-api] Make caret displayable before, after and in-between stub-elements as well as non-editable elements within editable contexts (#47)

[selection-api] Need to be able to tell if the caret is displayed at the beginning or the end of the line (#32)

[ServiceWorker] Add cookie accessor/setter methods? (#707)

[ServiceWorker] Add name param to Clients.openWindow() method (#711)

[ServiceWorker] caching of importScripts()-scripts (#106)

[ServiceWorker] Can Cache.add() committing at response resolution lead to duplicate requests? (#361)

[ServiceWorker] Can we replace event.default() with something less magic? (#607)

[ServiceWorker] Define the lifetime of a blob URL created inside a service worker (#688)

[ServiceWorker] Document the headers being introduced (#717)

[ServiceWorker] Does a SW control a page outside its scope reached by a redirect? (#706)

[ServiceWorker] How to deal with cookie bombing (#704)

[ServiceWorker] HTTP authentication and proxy authentication hook (#119)

[ServiceWorker] Interception of the fallback requests initiated from a SW for cross-origin resources (#684)

[ServiceWorker] Is Jake still a `ghost-author`? (#716)

[ServiceWorker] Limit Cache API to HTTPS (#709)

[ServiceWorker] Navigating clients from the SW context? (#681)

[ServiceWorker] navigator.serviceWorker is not defined (#689)

[ServiceWorker] Receivers of ranged responses must ensure all ranges come from the same underlying resource (#703)

[ServiceWorker] Restrict openWindow() to http(s) schemes? (#699)

[ServiceWorker] Service worker not receiving fetch events from iframe with Blob URL source. (#712)

[ServiceWorker] ServiceWorker registration fails inside an https-origin IFRAME when the top-level page is not secure (e.g. http or data URI) (#700)

[ServiceWorker] Should an IFRAME without src be controlled by SW when its parent is controlled? (#612)

[ServiceWorker] Should UUID for unique IDs be mandated? (#647)

[ServiceWorker] Should window.caches be removed (or readonly) for security reasons? (#698)

[ServiceWorker] spec should be more explicit about accessing internal body on opaque Responses (#710)

[ServiceWorker] Support restarting download when storing large resources in Cache (#713)

[ServiceWorker] UA shouldn't be required to invoke Soft Update on every navigation (#715)

[ServiceWorker] under what conditions should sandboxed iframes be intercepted? (#648)

[ServiceWorker] Unified naming (#708)

[ServiceWorker] updatefound event should be dispatched on ServiceWorkerRegistration (#714)

[ServiceWorker] What happens if there's an appcache manifest? (#275)

[ServiceWorker] What's proper SW name? :) (#705)

[ServiceWorker] Workers & SharedWorkers within ServiceWorkers (#678)

[ServiceWorker] You don't need any flags in Chrome today :) (#686)

[spec-reviews] CSV on the Web (#55)

[storage] Add API to allow origin to purge all storage (#4)

[storage] Restrict to Secure Contexts (#5)

[streams-api] Rescind this document (#1)

[streams] Add "when are streams appropriate" (#360)

[streams] Add .bytesRead to ReadableByteStream.*Reader (#367)

[streams] Add `.bytesRead` to ReadableByteStream.*Reader (#367)

[streams] Add ReadableByteStream observing API (#362)

[streams] Byte stream update, including reference implementation (#361)

[streams] compile into a single es5 file for polyfilling a browser and add bower.json (#369)

[streams] Consider moving stuff into ReadableStreamController (#364)

[streams] Don't allow negative-sized chunks (#370)

[streams] FAQs that need answers (#126)

[streams] Identity transform performance and ArrayBufferView ownership (#323)

[streams] Make sure promise returning methods don't throw (#342)

[streams] Never-released lock / getReader({unreleasable: true}) (#358)

[streams] Potentially simplify callOrScheduleAdvanceQueue (#145)

[streams] Readable byte streams should support an internal queue (#353)

[streams] Readable stream with ack (#324)

[streams] ReadableByteStream needs reference implementation/tests (#355)

[streams] ReadableByteStream underlying source/controller design: return a promise vs. c.something (#354)

[streams] ReadableByteStream: pull + pullInto or just pullInto (#363)

[streams] readBatch(), readAllAvailable() or getSyncReader() (#327)

[streams] Revert removal of _controller initialization, and add a comment to explain why it's necessary (a174501)

[streams] Should negative chunk size be allowed? (#368)

[streams] Transform streams and acknowledgement of writes (#329)

[streams] Update FAQ with some extra answers (#365)

[streams] Use "perform" for abstract ops that cannot throw (#366)

[streams] What should we call ReadableByteStream.prototype.getBYOBReader()? (#294)

[streams] What types does ReadableByteStream's reader's read(x) accept and return? (#295)

[uievents] #event-type-input and #event-type-beforeinput appear to have gone missing (#2)

[url] Counterintuitive step in `non-relative-url(input)` (#48)

[url] Make the textual description for port match the production rule (#49)

[webcomponents] [shadow-dom] [Fix #61] Make Event have isEncapsulated flag and use it in the event path calculation algorithm. (adae25b)

[webcomponents] [shadow-dom] Fix #102, updating Element.createShadowRoot() so that it throws an exception. (9b65780)

[webcomponents] [Shadow] Change the order of insertion points which are involved in a re-distribution in event path (bugzilla: 23887) (#98)

[webcomponents] [Shadow] createShadowRoot() in spec example should be updated to have parameter (#106)

[webcomponents] [Shadow] Focus on shadow host should slide to its inner focusable node (#105)

[webcomponents] [Shadow] investigate if there should be deepRelatedTargets and touch.deepTargets (bugzilla: 28560) (#76)

[webcomponents] [Shadow] Need Document.deepActiveElement (bugzilla:28652) (#104)

[webcomponents] [Shadow]: Add "closed" flag to createShadowRoot (bugzilla: 20144) (#100)

[webcomponents] [Shadow]: Add [TreatNullAs=EmptyString] to ShadowRoot.innerHTML (bugzilla: 28549) (#74)

[webcomponents] [Shadow]: Consider removal of multiple shadow roots (bugzilla: 28446) (#90)

[webcomponents] [Shadow]: Define the behavior of *closed* shadow trees. (bugzilla: 27775) (#85)

[webcomponents] [Shadow]: Distribution needs to not be observable (bugzilla: 27994) (#87)

[webcomponents] [Shadow]: Element.createShadowRoot() throws an exception for some elements (bugzilla: 27844) (#102)

[webcomponents] [Shadow]: elementFromPoint should return the host when you hit a Text node (bugzilla: 24638) (#67)

[webcomponents] [Shadow]: Event model (bugzilla: 28564) (#77)

[webcomponents] [Shadow]: Focus navigation in distributed content (#103)

[webcomponents] [Shadow]: Have a common interface between Document and ShadowRoot (bugzilla: 28493) (#91)

[webcomponents] [Shadow]: how is the autofocus attribute supposed to be handled? (bugzilla: 27757) (#97)

[webcomponents] [Shadow]: Multiple trees are introduced to explain encapsulation. (bugzilla: 23481) (#83)

[webcomponents] [Shadow]: rename <content> to <slot> (bugzilla: 28561) (#92)

[webcomponents] [Shadow]: Shadow host with tabindex=-1, all descendent tree should be ignored for tab navigation (bugzilla: 27965) (#86)

[webcomponents] [Shadow]: Specify imperative API for node distribution (bugzilla: 18429) (#60)

[webcomponents] [Shadow]: The return type of Event.path should leverage WebIDL sequences (bugzilla: 25458) (#101)

[webcomponents] [Shadow]: Update constraints around stopping events (bugzilla: 20247) (#61)

[webcomponents] Add "why upgrades" document to proposals section (#112)

[webcomponents] Add "why upgrades" document. (a042e52)

[webcomponents] Add a proposal md document for ShadowRoot's delegatesFocus flag. (#127)

[webcomponents] Add drawbacks to `is=` proposal (#117)

[webcomponents] Add notes on forms & script-supporting behaviour. (#116)

[webcomponents] Add Type-Extensions.md (#114)

[webcomponents] alternate proposal (#120)

[webcomponents] Clean up: refactor event path calculation algorithm and retargeting algorithm (#124)

[webcomponents] Describe focus navigation order for the case with tabindex=-1 (#35)

[webcomponents] Enumerate the element names which don't support createShadowRoot(), instead of looking at the binding property (#110)

[webcomponents] Enumerate the element names which don't support createShadowRoot(). (#110)

[webcomponents] Fixing 'slot id' to be 'slot name' (#122)

[webcomponents] Flesh out Accessibility benefits section (#115)

[webcomponents] getDistributedNodes() should return an Array (#108)

[webcomponents] getDistributedNodes() shouldn't exclude a node in closed shadow tree. (#109)

[webcomponents] importNode and adoptNode should throw with passed a ShadowRoot (#125)

[webcomponents] Introduce "delegatesFocus" flag to shadow root (#126)

[webcomponents] isEncapsulated naming (#107)

[webcomponents] Links on Introduction to Web Components don't actually take you anywhere (#123)

[webcomponents] Migrate the bugs filed for Custom Elements from bugzilla to GitHub Issues, here. (#119)

[webcomponents] Proposals directory contains non-Windows-compatible filenames (#111)

[webcomponents] Should parser extensibility be a design goal? (#113)

[webcomponents] Style edits to Type-Extensions.md (#118)

[webcomponents] Update Type-Extensions.md (#121)

[webidl-checker] Support for required dictionary member (#16)

[webidl] Fix arrays (#52)

[webidl] typo fix (#53)

[webidl] typo in the definition of an unrestricted double? (#51)

[webstorage] How to handle non-DOMString values? (#4)

[xhr] Abandon hope of removing sync XHR from the web platform? (#20)

[xhr] Drastically simplify FormData. Preserve object identity. Remove filename parameter now new File() covers that. (f9d4c25)

[xhr] getResponseHeader should work case-insensitive (#21)

[xhr] Remove XMLHttpRequest from ServiceWorkerGlobalScope (#19)

Last message date: Tuesday, 30 June 2015 18:42:59 UTC