public-webapps-bugzilla@w3.org from February 2014 by subject

[Bug 12607] Let authors control redirect behavior

[Bug 13912] What order are attributes in?

[Bug 14949] [Meta]: Component Model needs an Explainer document

[Bug 14968] [Meta]: Specify how custom elements work

[Bug 14978] [Meta]: Specify how shadow DOM works

[Bug 15417] Redirects and the base URL

[Bug 15480] [Shadow]: Things to Consider in the Future

[Bug 16229] [Shadow]: Consider a combinator for activating content when a selector matches

[Bug 16487] EventTarget constructor

[Bug 16491] Add simpler and better event registration system

[Bug 16509] [Shadow]: Consider isolation

[Bug 17125] Add a FileList.drop(index) method

[Bug 17426] Consider adding a replaceContents() method

[Bug 17541] Carefully think through how Range.insertNode should behave when the node to be inserted is already at the beginning of the range

[Bug 17648] [Awaiting ES6] Add iterators

[Bug 17713] Exceptions thrown from event handlers should not be propagated

[Bug 17871] Element attributes should not be required to be stored in an ordered list

[Bug 18362] Make stringifiers not take into account expandos

[Bug 18429] [Shadow]: Specify imperative API for node distribution

[Bug 18752] [Shadow]: Change default behavior for <content> element

[Bug 18753] [Shadow]: Introduce HTMLContentElement projection API

[Bug 18755] [Shadow]: Introduce ShadowRoot distribution callback

[Bug 18756] [Shadow]: Add "author-distributed" flag to shadow root machinery

[Bug 18780] Fix event dispatching for shadow DOM and <iframe seamless>

[Bug 19962] Add insertAdjacentText and insertAdjacentElement?

[Bug 20144] [Shadow]: Consider adding "private" flag to createShadowRoot

[Bug 20158] Unrestricted typed dictionary

[Bug 20236] 3.1.1.1 button value -1 isn't possible

[Bug 20295] [Shadow]: Make all Method/Attribute descriptions consistent

[Bug 20567] Change [[Prototype]] for concept-node-adopt?

[Bug 20654] Have Range.surroundContents() work for partially contained nodes?

[Bug 20660] DOMTokenList list of tokens isn't properly initialised

[Bug 20683] [Imports]: Write HTML Imports spec

[Bug 20713] Consider defining window.event and Event.srcElement

[Bug 20958] [Shadow]: Consider dropping resetStyleInheritance in favor of a CSS property

[Bug 20976] Define Node.baseURI properly

[Bug 21275] [Imports]: Force utf-8

[Bug 21650] Require that XHR is available in workers

[Bug 21740] Guidance on DOMError and promises

[Bug 22128] [Shadow]: Define what "inserted into document" means for elements in shadow tree

[Bug 22169] [Shadow]: Nit: Update StyleSheetList definition link

[Bug 22305] [imports]: Imports should be represented as Documents, not DocumentFragments.

[Bug 22409] Custom elements need da (microtask) hookup

[Bug 22540] Fire event when database connection is closed without explicit close() call

[Bug 22711] Add a .empty method to the ParentNode (or the Node?) interface

[Bug 22715] [Shadow]: [Meta] New features and improvements

[Bug 22716] [Shadow]: [Meta] Cleanup, refactoring, and polish

[Bug 22790] [Shadow]: Rename 'insertion points' to 'distribution points'.

[Bug 22892] [Shadow]: What (if anything) does <style scoped> do, when it is a child of a shadow host?

[Bug 23062] [Shadow DOM styling]: Style related issues

[Bug 23095] "Call listener's callback's handleEvent, with th..."

[Bug 23134] [Shadow]: createShadowRoot() should receive dictionary to initialize flags

[Bug 23147] Describe File API Model

[Bug 23170] [imports]: Why not have imported documents share their importing document's defaultView?

[Bug 23186] EventListener argument of addEventListener and removeEventListener should not be nullable

[Bug 23226] Need for Virtual MutationRecords

[Bug 23264] Investigate returning Elements from querySelector and querySelectorAll

[Bug 23268] Cannot describe NodeIterator in terms of "node is removed"

[Bug 23278] [imports]: Things to Consider in the Future

[Bug 23346] Use TypeError for argument validation

[Bug 23367] Move exceptions into IDL

[Bug 23519] [imports]: It is not clear when import is ready.

[Bug 23526] [imports]: blocking DOMContentLoaded while HTML imports are loaded

[Bug 23578] [Shadow]: Classes misused in Events Retargeting Example

[Bug 23636] [Shadow]: selectors in style elements in shadowRoots should match in sibling shadowRoots

[Bug 23682] Fix the current [ArrayClass], [] and sequence<T> mess

[Bug 23697] KeyboardEventInit in UI Events doesn't include keyCode/charCode/which but in D3E, it includes them

[Bug 23707] Use a switch for the checks on children of a document

[Bug 23725] Consider strongly-defined createStream to add generic stream support for APIs

[Bug 23793] "For each element e in elementSet, append the el..."

[Bug 23810] When adopting, "If node is an element, it is affected by a base..."

[Bug 23839] [Custom]: Template document should not share registry with its document

[Bug 23853] Please clarify the interpretation of the WebIDL undefined Date in the File constructor

[Bug 23886] Needs to define key value when dead key is pressed twice

[Bug 23887] [Shadow] Put only the final destination insertion point to the event path

[Bug 23915] DOMTokenList "tokens" never updated

[Bug 23943] It's too difficult to search the code which access KeyboardEvent.key

[Bug 23946] Lift the ban on query parts in “blob:” URIs

[Bug 23975] [Streams API] Remove read as Blob support

[Bug 23977] [Streams API] Generic object stream

[Bug 24002] [imports]: import attribute on the LinkImport interface should be |Document?| instead of |Document|

[Bug 24003] [Imports]: Element removed flag's behavior is not clear if multiple HTMLLinkElement refers to the same import

[Bug 24010] [Shadow]: What if there is no common ancestor?

[Bug 24012] [Shadow]: lowest common inclusive ancestor tree needs to include shadow trees?

[Bug 24028] Element.matches("!invalid!") should throw SyntaxError, not TypeError

[Bug 24042] [imports]: document.write() in imports should do nothing.

[Bug 24042] [imports]: Parser should not wait on external resources inside imports

[Bug 24072] Clarify handling of neutered objects

[Bug 24087] [Custom]: Rename document.register to registerElement

[Bug 24087] [Custom]: Rename document.registerElement to defineElement

[Bug 24102] Specify the targets for events

[Bug 24106] FKA: No defined way to get keyboard focus into and out of a shadow DOM component

[Bug 24114] [imports]: add support for async loading

[Bug 24174] < should be quoted in attribute values

[Bug 24178] [Custom]: No way to differentiate attribute namespaces in attributeChanged callback

[Bug 24181] [Shadow]: There's isn't a way to append shadow elements in SVG

[Bug 24208] Please handle the case of XML attributes with namespaces but no prefix

[Bug 24247] "guidelines for selecting and defining key values" is a dead link

[Bug 24271] Document.createElement name validation inconsistent with HTML parse rules

[Bug 24314] [Custom]: enteredView and leftView callbacks are still confusing

[Bug 24316] [Shadow]: implement :ancestor and change :host behavior

[Bug 24318] Define the Realm of objects

[Bug 24338] Spec should have Fetch for Blob URLs

[Bug 24339] File API should specify Blob.close() with a state in the model and influence on read methods

[Bug 24349] [imports]: Import documents should always be in no-quirks mode

[Bug 24401] abort() should always dispatch loadend

[Bug 24403] WebIDL callbacks should probably default to pushing a new entry settings object

[Bug 24421] [Shadow]: Clarify that Shadow DOM spec takes care of nodes which are *inDocument*.

[Bug 24453] Expose interfaces to workers

[Bug 24469] Definition of "valid blob" is unclear and probably wrong

[Bug 24469] New: Definition of "valid blob" is unclear and probably wrong

[Bug 24470] Link to #networkError in fetching section is broken

[Bug 24470] New: Link to #networkError in fetching section is broken

[Bug 24474] New: StorageQuota.requestPersistentQuota() should use [Clamp] on newQuota argument

[Bug 24474] StorageQuota.requestPersistentQuota() should use [Clamp] on newQuota argument

[Bug 24475] New: StorageQuota.supportedTypes should not use Array which is to be deprecated

[Bug 24475] StorageQuota.supportedTypes should not use Array which is to be deprecated

[Bug 24475] StorageQuota.supportedTypes should return a frozen Array

[Bug 24477] New: Preparation for spec converging

[Bug 24477] Preparation for spec converging

[Bug 24479] New: [Streams] Bug: Unable to notify EOF after delivering the last element separately

[Bug 24481] Markup error around blob URL store

[Bug 24481] New: Markup error around blob URL store

[Bug 24523] New: Spec should mention how fullscreen works on fragmented elements

[Bug 24523] Spec should mention how fullscreen works on fragmented elements

[Bug 24555] [imports]: Preceding import should block following document from processing.

[Bug 24555] New: [imports]: Preceding import should block following document from processing.

[Bug 24557] [Shadow]: The definition of focus navigation is misleading.

[Bug 24557] New: [Shadow]: The definition of focus navigation is misleading.

[Bug 24564] [Imports]: Blocking circular reference in the import tree/list

[Bug 24564] New: [Imports]: Blocking circular reference in the import tree/list

[Bug 24565] [imports]: Dependency resolution should be stated in clearer way

[Bug 24565] New: [imports]: Dependency resolution should be stated in clearer way

[Bug 24570] [Custom]: Callback for cloneNode/importNode

[Bug 24570] New: [Custom]: Callback for cloneNode/importNode

[Bug 24573] Clarify non-null Blob

[Bug 24573] New: Clarify non-null Blob

[Bug 24575] "HTML5"

[Bug 24575] New: "HTML5"

[Bug 24576] Calling URL.createObjectURL() on a closed Blob

[Bug 24576] New: Calling URL.createObjectURL() on a closed Blob

[Bug 24577] [Custom]: Need adopted callback

[Bug 24577] New: [Custom]: Need adopted callback

[Bug 24578] New: [Custom]: define registry primitive

[Bug 24579] [Custom]: make callbacks more explicit

[Bug 24579] New: [Custom]: make callbacks more explicit

[Bug 24580] New: "Let cast be the original value of %Promise%.cast. "

[Bug 24581] New: Fix ByteString type & [EnsureUTF16] flag story

[Bug 24583] [imports]: failed fetch should result null document in import list

[Bug 24583] New: [imports]: failed fetch should result null document in import list

[Bug 24586] New: Remove FileList

[Bug 24586] Remove FileList

[Bug 24600] [Custom]: Callback names are out of date?

[Bug 24600] New: [Custom]: Callback names are out of date?

[Bug 24603] [Custom]: Need callback for form submit data

[Bug 24603] New: [Custom]: Need callback for form submit data

[Bug 24608] New: What happens when calling lockOrientation() and already locked?

[Bug 24608] What happens when calling lockOrientation() and already locked?

[Bug 24609] Can unlockOrientation() cause an orientationchange event to be fired?

[Bug 24609] New: Can unlockOrientation() cause an orientationchange event to be fired?

[Bug 24610] New: What happens when unlockOrientation() is called but no orientation is locked?

[Bug 24610] What happens when unlockOrientation() is called but no orientation is locked?

[Bug 24611] New: Should the screen orientation be unlocked when navigating to a new page?

[Bug 24612] New: Should Screen locking work only in full screen mode?

[Bug 24612] Should Screen locking work only in full screen mode?

[Bug 24614] New: Should the screen orientation be unlocked asynchronously

[Bug 24614] Should the screen orientation be unlocked asynchronously

[Bug 24616] [imports]: Stylesheets in imported documents should be loaded

[Bug 24616] New: [imports]: Stylesheets in imported documents should be loaded

[Bug 24624] Is the order of HTMLCollection's supported property names valid?

[Bug 24624] New: Is the order of HTMLCollection's supported property names valid?

[Bug 24627] [Shadow]: Support disconnected nodes

[Bug 24627] New: [Shadow]: Support disconnected nodes

[Bug 24629] [Explainer]: attachedCallback / detachedCallback are now enteredView and leftView?

[Bug 24629] New: [Explainer]: attachedCallback / detachedCallback are now enteredView and leftView

[Bug 24632] [meta][imports]: The spec should have fewer monkey patches

[Bug 24632] New: [meta][imports]: The spec should have fewer monkey patches

[Bug 24637] [imports] "style sheet that is blocking scripts" should be generalized to support HTML Imports

[Bug 24637] New: [imports] "style sheet that is blocking scripts" should be generalized to support HTML Imports

[Bug 24638] [Shadow]: elementFromPoint should return the host when you hit a Text node

[Bug 24638] New: [Shadow]: elementFromPoint should return the host when you hit a Text node

[Bug 24639] [Shadow]: Each section on the spec needs examples

[Bug 24639] New: [Shadow]: Each section on the spec needs examples

[Bug 24652] Deal with associated Realms

[Bug 24652] New: Deal with associated Realms

[Bug 24653] Planning on changing mutation hooks

[Bug 24655] New: [Custom]: Consider turning processing stack + queues into its own primitive

[Bug 24658] [imports]: The fetch readiness shouldn't block fetching.

[Bug 24658] New: [imports]: The fetch readiness shouldn't block fetching.

[Bug 24668] New: "To set the start or end of a range to a boundary point" should check owner document

[Bug 24691] New: Allow shared Web workers to persist across page loads from same origin

[Bug 24692] Define 'default orientation'

[Bug 24692] New: Define 'default orientation'

[Bug 24695] New: Allowed orientations should be an enum

[Bug 24697] New: Use Promises for lockOrientation and unlockOrientation

[Bug 24698] New: Expose/lock to the screen orientation angle

[Bug 24699] New: Reconsider -primary and -secondary orientations

[Bug 24700] New: Should 'foo' be entirely equivalent to [ 'foo-primary', 'foo-secondary' ]

[Bug 24701] Apply Marcos' comments

[Bug 24701] New: Apply Marcos' comments

[Bug 24702] Apply Anne's comments sent in public-webapps

[Bug 24702] New: Apply Anne's comments sent in public-webapps

[Bug 24703] New: No easy way to lock to a set of accepted orientations if one UA doesnt support one of them

[Bug 24703] No easy way to lock to a set of accepted orientations if one UA doesnt support one of them

[Bug 24708] [Shadow]: Wrong spelling

[Bug 24708] New: [Shadow]: Wrong spelling

[Bug 24725] New: Use the microtask queue for MutationObserver

[Bug 24725] Use the microtask queue for MutationObserver

[Bug 24729] New: WeelEvent inherits from MouseEvent, but WheelEventInit (UIevents) doesn't from MouseEventInit

[Bug 24729] WeelEvent inherits from MouseEvent, but WheelEventInit (UIevents) doesn't from MouseEventInit

[Bug 24732] New: Remove DOMError from FileAPI

[Bug 24732] Remove DOMError from FileAPI

[Bug 24738] New: D3E spec should define if keypress is fired when preceding beforeinput is consumed by preventDefault()

[Bug 24739] New: Define code values for the special keys on Sun keyboard

[Bug 24740] New: Define code values for the special keys on Mac keyboard

[Bug 24741] New: CustomEvent inherits from Event

[Bug 24751] New: "continue"

[Bug 24756] New: [imports]: Cascading order for stylesheets of imported documents should be stated more clearly

[Bug 24789] "Developers must not pass false for the async ar..."

[Bug 24789] New: "Developers must not pass false for the async ar..."

[Bug 24790] "Developers must not pass false for the async ar..."

[Bug 24790] New: "Developers must not pass false for the async ar..."

[Bug 24795] New: < should be quoted in attribute values

[Bug 24797] New: Stop using AbstractView

[Bug 24808] [imports]: document.write() in imports should do nothing.

[Bug 24808] New: [imports]: document.write() in imports should do nothing.

[Bug 24810] New: "invoke MutationObserver object" should be updated for microtasks

[Bug 24819] New: "The error, abort, and load event types are mutu..."

[Bug 24823] [ServiceWorker]: "MAY NOT" is not defined in RFC 2119

[Bug 24823] New: [ServiceWorker]: "MAY NOT" is not defined in RFC 2119

[Bug 24844] New: Spec is missing <body> and <head> elements

[Bug 24844] Spec is missing <body> and <head> tags

[Bug 24848] [imports]: ES6 module loader should be aware modules in HTML Imports

[Bug 24848] New: [imports]: ES6 module loader should be aware modules in HTML Imports

[Bug 24861] [Shadow]: Add a way to detect when the list of nodes distributed to an insertion point mutates

[Bug 24861] New: [Shadow]: Add a way to detect when the list of nodes distributed to an insertion point mutates

[Bug 24865] New: Remove requirement that highest version request is processed first

[Bug 24865] Remove requirement that highest version request is processed first

[Bug 24866] [Custom]: Consider adding inserted/removed callback

[Bug 24866] New: [Custom]: Consider adding inserted/removed callback

[Bug 24867] [Shadow]: consider supporting :not() in content select

[Bug 24867] New: [Shadow]: consider supporting :not() in content select

[Bug 24870] [Shadow]: HTMLTitleElement shouldn't work in shadow trees

[Bug 24870] New: [Shadow]: HTMLTitleElement shouldn't work in shadow trees

[Bug 24872] [Shadow]: Consider adding back at least :first-of-type to valid matching criteria

[Bug 24872] New: [Shadow]: Consider adding back at least :first-of-type to valid matching criteria

Last message date: Friday, 28 February 2014 23:59:59 UTC