public-webapps-bugzilla@w3.org from April 2014 by subject

[Bug 10583] [Selection] toString should return only the text within the selection that is visible to the user

[Bug 13909] Selections have three possible directions, not two

[Bug 13952] Specify selection change events

[Bug 13974] Allow Selections to be cloned, saved, etc.

[Bug 14949] [Meta]: Component Model needs an Explainer document

[Bug 14968] [Meta]: Specify how custom elements work

[Bug 14978] [Meta]: Specify how shadow DOM works

[Bug 15470] Changing the selection creates a Range object

[Bug 16509] [Shadow]: Consider isolation

[Bug 17541] Carefully think through how Range.insertNode should behave when the node to be inserted is already at the beginning of the range

[Bug 18429] [Shadow]: Specify imperative API for node distribution

[Bug 19936] consider allowing non-matching enums to be converted to a particular value

[Bug 20144] [Shadow]: Add "private" flag to createShadowRoot

[Bug 20600] [Shadow]: Custom Pseudo-Elements should follow the same convention as custom element names.

[Bug 20683] [Imports]: Write HTML Imports spec

[Bug 20957] [Shadow]: Styling elements in shadow trees based on host element

[Bug 21202] [Shadow]: Specify how :host() interacts with the scoped styles

[Bug 21275] [Imports]: Force utf-8

[Bug 21740] Guidance on DOMError and promises

[Bug 21992] Consider adding .inputMethodContext to SVGElement

[Bug 22018] Consider adding getCompositionAlternatives() in InputMethodContext

[Bug 22059] Composition dictionary should be changed

[Bug 22305] [imports]: Imports should be represented as Documents, not DocumentFragments.

[Bug 22320] Form's supported property names should perhaps not be enumerable

[Bug 22390] [Shadow]: Support ':host()' pseudo class.

[Bug 22646] So if we want to say on a per-object basis whether it ought to be exposed to workers (which I think is useful) lets introduce "exposed to document environments", "exposed to worker environments", and [...]

[Bug 22705] createImageBitmap in WorkerGlobalScope can only take a subset ImageBitmapSource types

[Bug 22715] [Shadow]: [Meta] New features and improvements

[Bug 23033] Requesting PermissionDeniedError to be added

[Bug 23062] [Shadow DOM styling]: Style related issues

[Bug 23072] Interaction with DeviceOrientation/Motion

[Bug 23167] [D3E-code] Define key name for TV

[Bug 23167] Define key name for TV

[Bug 23170] [imports]: Why not have imported documents share their importing document's defaultView?

[Bug 23268] Cannot describe NodeIterator in terms of "node is removed"

[Bug 23278] [imports]: Things to Consider in the Future

[Bug 23369] Provide hooks for Typed Arrays

[Bug 23467] [Shadow]: clarify ^ and ^^ combinator

[Bug 23526] [imports]: blocking DOMContentLoaded while HTML imports are loaded

[Bug 23697] KeyboardEventInit in UI Events doesn't include keyCode/charCode/which but in D3E, it includes them

[Bug 23748] Shouldn't getModifierState() definition refer Modifiers Keys which are defined in .key value?

[Bug 23750] ScrollLock key should be defined in 6.3.2 Modifier Keys

[Bug 23751] "Select" key is not defined in the latest ED

[Bug 23830] Move attributes of Composition interface to CompositionEvent

[Bug 23853] Please clarify the interpretation of the WebIDL undefined Date in the File constructor

[Bug 23886] Needs to define key value when dead key is pressed twice

[Bug 23887] [Shadow] Put only the final destination insertion point to the event path

[Bug 23906] [proposal] Add (Mouse|Keyboard)Event.accelKey

[Bug 23908] What's the good key value of printable keys with Meta key (Command key) on Mac?

[Bug 23909] Which is expected whether keydown event is fired before or after native IME handles it

[Bug 23910] What's the good .key value while IME is open?

[Bug 23911] [Proposal] Add KeyboardEvent.isComposing attribute

[Bug 23913] beforeinput should be fired only when the DOM change is caused by direct input by keypress or composition

[Bug 24028] Element.matches("!invalid!") should throw DOMException "SyntaxError", not JavaScript TypeError

[Bug 24042] [imports]: Parser should not wait on external resources inside imports

[Bug 24044] How do browsers decide combining character from non-combining character at computing .key value of dead key?

[Bug 24083] Window.getSelection() and HTMLDocument.getSelection() should return a nullable

[Bug 24084] Specify Selection.containsNode

[Bug 24247] "guidelines for selecting and defining key values" is a dead link

[Bug 24288] [Shadow]: Revert <shadow> element as a function call feature.

[Bug 24349] [imports]: Import documents should always be in no-quirks mode

[Bug 24576] Calling URL.createObjectURL() on a closed Blob

[Bug 24611] Should the screen orientation be unlocked when navigating to a new page?

[Bug 24632] [meta][imports]: The spec should have fewer monkey patches

[Bug 24637] [imports] "style sheet that is blocking scripts" should be generalized to support HTML Imports

[Bug 24697] Use Promises for lockOrientation

[Bug 24698] Expose/lock to the screen orientation angle

[Bug 24738] D3E spec should define if keypress is fired when preceding beforeinput is consumed by preventDefault()

[Bug 24739] [D3E-code] Define code values for the special keys on Sun keyboard

[Bug 24739] Define code values for the special keys on Sun keyboard

[Bug 24740] Define code values for the special keys on Mac keyboard

[Bug 24797] Stop using AbstractView

[Bug 24808] [imports]: document.write() in imports should do nothing.

[Bug 25007] [imports]: Want New LinkImport method to return a promise.

[Bug 25053] Specify clear security requirements

[Bug 25054] Should the API be exposed to non-Mobile?

[Bug 25061] [Shadow]: Minor grammatical quibble

[Bug 25081] Make read operation really async

[Bug 25086] Attr should retain ownerElement property

[Bug 25088] 'orientationchange' should fire on Window so that there can be a <body> event handler for it

[Bug 25168] Should XML Serialization be allowed to produce invalid XML?

[Bug 25180] Handle <template> element serialization

[Bug 25210] Targets for abort event is correct?

[Bug 25223] IDB exposes GC behavior

[Bug 25223] New: IDB exposes GC behavior

[Bug 25225] New: No way to convert between XML and HTML documents

[Bug 25225] No way to convert between XML and HTML documents

[Bug 25229] New: Shouldn't NumpadComma be NumpadSeparator?

[Bug 25229] Shouldn't NumpadComma be NumpadSeparator?

[Bug 25240] Blob.close() shouldn't throw when invoked more than once.

[Bug 25240] New: Blob.close() shouldn't throw when invoked more than once.

[Bug 25241] New: FileReader.readAsXxx methods should not throw on CLOSED

[Bug 25242] Blob.close should not set the blob's size to 0 or cause slice() to throw

[Bug 25242] New: Blob.close should not set the blob's size to 0 or cause slice() to throw

[Bug 25244] New: What do Attr objects serialize?

[Bug 25244] What do Attr objects serialize?

[Bug 25251] New: Transaction ordering for readonly transactions

[Bug 25283] [Custom]: Custom element names should not end with a hyphen

[Bug 25283] New: [Custom]: Custom element names should not end with a hyphen

[Bug 25287] [Proposa] InputEvent should have isComposing too

[Bug 25287] New: [Proposa] InputEvent should have isComposing too

[Bug 25288] New: Should change the definition of InputEvent.isComposing

[Bug 25288] Should change the definition of InputEvent.isComposing

[Bug 25290] [Custom]: Ban uppercase and leading "xml" in custom element names?

[Bug 25290] New: [Custom]: Ban uppercase and leading "xml" in custom element names?

[Bug 25291] New: Should define input event should be fired after compositionend

[Bug 25291] Should define input event should be fired after compositionend

[Bug 25294] DOMParser.parseFromString with application/whatever+xml

[Bug 25294] New: DOMParser.parseFromString with application/whatever+xml

[Bug 25295] New: Small bugs in the descriptions

[Bug 25295] Small bugs in the descriptions

[Bug 25300] New: WebIDL needs to be updated to new terminology around script settings objects

[Bug 25302] Blob objects should have a keepalive list of objects

[Bug 25302] New: Blob objects should have a keepalive list of objects

[Bug 25303] New: Small bugs in the descriptions

[Bug 25303] Small bugs in the descriptions

[Bug 25310] New: Move the HTML specification monkey patching to the HTML specification

[Bug 25311] New: Keep consistency wrt the screen definition with CSS View

[Bug 25312] allow trailing commas on enums

[Bug 25312] New: allow trailing commas on enums

[Bug 25313] New: Improve and add examples

[Bug 25314] New: screen.orientation.angle should be an unsigned short

[Bug 25314] screen.orientation.angle should be an unsigned short

[Bug 25319] [imports]: Want some kind of imperative API

[Bug 25319] New: [imports]: Want some kind of imperative API

[Bug 25329] Do not allow locking to angles

[Bug 25329] New: Do not allow locking to angles

[Bug 25338] D3E spec should recommend KeyboardEvent.code mapping of some keys whose label are different from PC's keyboard

[Bug 25338] D3E spec should recommend that KeyboardEvent.code of some keys whose label are different from PC's keyboard should be mapped from the key labels on Mac keyboard

[Bug 25338] New: D3E spec should recommend KeyboardEvent.code mapping of some keys whose label are different from PC's keyboard

[Bug 25340] Define new code name NumpadEqual or NumpadEquals

[Bug 25340] New: Define new code name NumpadEqual or NumpadEquals

[Bug 25343] Expose an isClosed property on Blob Objects

[Bug 25343] New: Expose an isClosed property on Blob Objects

[Bug 25346] New: Redefine initMouseEvent()

[Bug 25346] Redefine initMouseEvent()

[Bug 25357] New: Target for event type is not complete

[Bug 25357] Target for event type is not complete

[Bug 25358] "Context info: UIEvent.view" sometimes only has defaultView

[Bug 25358] New: "Context info: UIEvent.view" sometimes only has defaultView

[Bug 25359] New: Use [Unforgeable] and [NewObject] annotations in D3E

[Bug 25359] Use [Unforgeable] and [NewObject] annotations in D3E

[Bug 25363] Event click in table (adjustment default action)

[Bug 25363] New: Event click in table (adjustment default action)

[Bug 25365] About trusted="false" in two event orders

[Bug 25365] New: About trusted="false" in two event orders

[Bug 25366] Cancelable for mousemove (add note)

[Bug 25366] New: Cancelable for mousemove (add note)

[Bug 25368] New: Self-referential Informative reference appears at the bottom of the document

[Bug 25368] Self-referential Informative reference appears at the bottom of the document

[Bug 25370] Specify document.createAttributeNS

[Bug 25373] "NonConvert" (key) vs. "NoConvert" (code)

[Bug 25373] New: "NonConvert" (key) vs. "NoConvert" (code)

[Bug 25391] New: Add default to a sequence e.g. sequence<DOMString> = [];

[Bug 25392] "Unset the stop propagation flag, stop immediate..."

[Bug 25392] New: "Unset the stop propagation flag, stop immediate..."

[Bug 25400] [Shadow]: elementFromPoint is incorrect

[Bug 25400] New: [Shadow]: elementFromPoint is incorrect

[Bug 25405] Input Event Types (some correct)

[Bug 25405] New: Input Event Types (some correct)

[Bug 25408] New: Small typos

[Bug 25408] Small typos

[Bug 25412] Allow some recursion in NodeIterator/TreeWalker

[Bug 25412] New: Allow some recursion in NodeIterator/TreeWalker

[Bug 25421] New: Split the key/code value tables out of the primary DOM3 Events spec.

[Bug 25421] Split the key/code value tables out of the primary DOM3 Events spec.

[Bug 25423] [Shadow]: event.path should return every nodes in the event path, instead of erasing nodes on descendant trees.

[Bug 25423] New: [Shadow]: event.path should return every nodes in the event path, instead of erasing nodes on descendant trees.

[Bug 25425] New: enum should be able to inherit from another enum

[Bug 25428] hasFeature removal was premature

[Bug 25428] New: hasFeature removal was premature

[Bug 25430] New: NodeIterator mutation algorithm is totally broken

[Bug 25430] NodeIterator mutation algorithm is totally broken

[Bug 25435] #concept-node-insert references index child, which may be null

[Bug 25435] New: #concept-node-insert references index child, which may be null

[Bug 25448] Keyboard Event Types (some correct)

[Bug 25448] New: Keyboard Event Types (some correct)

[Bug 25451] DOM spec header

[Bug 25451] New: DOM spec header

[Bug 25457] Adding "AutocompleteError" to error names table

[Bug 25457] New: Adding "AutocompleteError" to error names table

[Bug 25458] [Shadow]: The return type of Event.path should be EventTarget[], instead of NodeList

[Bug 25458] New: [Shadow]: The return type of Event.path should be EventTarget[], instead of NodeList

[Bug 25467] [imports]: Dynanically added imports should block following imports.

[Bug 25467] New: [imports]: Dynanically added imports should block following imports.

[Bug 25470] [imports]: improve description of async to clarify execution order

[Bug 25470] New: [imports]: improve description of async to clarify execution order

[Bug 25473] New: [Custom]: Add support for focus navigation similar to input type=date

[Bug 25477] KeyboardEvent.initKeyboardEvent() needs correct

[Bug 25477] New: KeyboardEvent.initKeyboardEvent() needs correct

[Bug 25484] [Explainer]: Example querySelectors need to select IDs

[Bug 25484] New: [Explainer]: Example querySelectors need to select IDs

[Bug 25485] D3E and corelation with DOM4(W3C)/DOM(WHATWAG) and DOM3 Core

[Bug 25485] New: D3E and corelation with DOM4(W3C)/DOM(WHATWAG) and DOM3 Core

[Bug 25489] [Imports]: Script execution order is non-deterministic in cyclic cases

[Bug 25489] New: [Imports]: Script execution order is non-deterministic in cyclic cases

[Bug 25491] createEvent and case significance

[Bug 25491] New: createEvent and case significance

[Bug 25494] New: What is the status of this document?

[Bug 25494] What is the status of UI Events document?

[Bug 25495] New: Behavior of no [Exposed] on interface members is weird

[Bug 25499] New: Upgrade event tables for better description

[Bug 25499] Upgrade event tables for better description

[Bug 25510] New: Spec readability: Move glossary to the bottom

[Bug 25510] Spec readability: Move glossary to the bottom

[Bug 9514] [Selection] Specify Selection.modify()

Last message date: Wednesday, 30 April 2014 23:59:09 UTC