[Bug 22565] [Custom]: rename inserted/removedCallback to entered/leftDocumentCallback

https://www.w3.org/Bugs/Public/show_bug.cgi?id=22565

--- Comment #2 from Daniel Buchner <danieljb2@gmail.com> ---
(In reply to comment #0)
> The inserted/removed aren't as precise in describing the reason they're
> called, which is when the custom element enters or leaves the document.

I agree with Anne, developers are more likely to recognize these actions as
'inserted' and 'removed' - remove(), removeChild(), insertBefore(), DOM Level 3
Mutation Event legacy, etc. I would rather see the API use method names that
mirror what developers are already thinking and are instantly recognizable,
than ones that are excessively descriptive and obtuse.

In addition, are entered/leftDocument really correct? What happens when I move
a node by reference that is already in the DOM to another place in the DOM? For
example:

  <ul>
    <li id="one"></li>
    <li id="two"></li>
    <li id="three"></li>
  </ul>

  var one = document.getElementById('one'),
      three = document.getElementById('three');

  one.parentNode.insertBefore(one, three);

Does 'one' ever leave the document before insertion above 'three'? Further,
even if it _technically_ does, would everyday developers actually be aware of
such a nuance?

All this goes to the point that while enter/left may be a bit more technically
correct (assuming it is still so in the above case - albeit briefly),
developers are conditioned (for various reasons) to associate this behavior
with inserted/removed.

-- 
You are receiving this mail because:
You are the QA Contact for the bug.

Received on Saturday, 13 July 2013 04:24:03 UTC