W3C home > Mailing lists > Public > public-webapi@w3.org > July 2007

Re: Selectors API Method Names

From: Maciej Stachowiak <mjs@apple.com>
Date: Mon, 2 Jul 2007 10:55:44 -0700
Message-Id: <A25B8ACD-E6C9-475E-A5F2-0EAEAF6A8C65@apple.com>
Cc: Lachlan Hunt <lachlan.hunt@lachy.id.au>, public-webapi <public-webapi@w3.org>
To: Charles McCathieNevile <chaals@opera.com>

On Jul 2, 2007, at 2:18 AM, Charles McCathieNevile wrote:

> On Thu, 28 Jun 2007 12:20:37 +0200, Lachlan Hunt  
> <lachlan.hunt@lachy.id.au> wrote:
>> Would others accept changing the methods to cssQuery() and  
>> cssQueryOne()?  If this would achieve concensus, I'd be willing to  
>> use these names.
> Opera does not like the cssQuery names and prefers the names that  
> were suggested in Lachy's draft.
> I recall strong objection to names which suggested this was about  
> CSS in the past (but maybe it was only Anne objecting) on the basis  
> that this isn't about CSS but selectors.
> So, Bjoern, Maciej, do you object to closing the issue with the  
> names Lachy proposed in his draft, or are you just tossing in  
> another idea in case it gets stronger consensus?

I don't have a strong objection either way, but I think the case  
against Lachy's original names (selectElement, etc) has been laid out  
more clearly than the case against cssQuery. I think selectorQuery  
(as suggested in follow-ups) would also be ok.

Received on Monday, 2 July 2007 17:55:55 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:24 UTC