W3C home > Mailing lists > Public > public-webapi@w3.org > February 2007

Re: Proposal: getElementsBySelector()

From: Maciej Stachowiak <mjs@apple.com>
Date: Tue, 6 Feb 2007 04:11:03 -0800
Message-Id: <FE89145A-66A8-4D07-A9A5-11FFF9E3F44F@apple.com>
Cc: Anne van Kesteren <annevk@opera.com>, "Web API WG (public)" <public-webapi@w3.org>
To: Charles McCathieNevile <chaals@opera.com>

On Feb 5, 2007, at 10:18 PM, Charles McCathieNevile wrote:

> On Sun, 28 Jan 2007 13:41:10 +0530, Anne van Kesteren  
> <annevk@opera.com> wrote:
>> Given the input from Björn I suppose there's no real need for a  
>> method
>> that returns a single element node (assuming implementations make  
>> that
>> optimization). Given that, I propose we rename .getAll() to
>> .getElementsBySelector() and drop .get() (on both Document and  
>> Element).
>> One advantage is that it's consistent with the naming people  
>> already use
>> for custom written functions that have this functionality. In  
>> theory it's
>> also not harder to type than .getElementsByTagName(). The only  
>> thing that
>> makes it differ from the other getElementsBy* method(s) is that it  
>> doesn't
>> return a live NodeList. I don't see that as a major problem.
>> If there are no strong objections I'll implement this in the  
>> specification.
> Not having heard strong objections, and having had support for
> getElementsBySelector() that is at least as strong as anything  
> else, I think (with
> my chair's hat) this can be taken as the current resolution of the  
> naming debate.
> Which would also resolve ISSUE-110.
> Any objections?

I stated my objection already in my message on this thread from  
January 28th.

Received on Tuesday, 6 February 2007 12:11:31 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:57 GMT