W3C home > Mailing lists > Public > public-webapi@w3.org > December 2007

Re: ISSUE-119: names lengthComputable and total

From: Maciej Stachowiak <mjs@apple.com>
Date: Mon, 10 Dec 2007 07:28:57 -0800
Cc: Jean-Yves Bitterlich <Jean-Yves.Bitterlich@sun.com>, "Web API WG (public)" <public-webapi@w3.org>
Message-Id: <FEDF234F-3CB0-4387-991D-342456C3D5FA@apple.com>
To: Charles McCathieNevile <chaals@opera.com>


On Dec 10, 2007, at 7:15 AM, Charles McCathieNevile wrote:

>
> Ikivo have told me that they also implemented already with the  
> existing event names, and would write to say so.
>
> I am therefore resolving this issue by not changing the names.

I don't think the JSR objection is very strong, since JSR-280 says:

"Note – Note that MouseWheelEvent and ProgressEvent are newly included  
in the W3C DOM3 draft specification and have not yet gone through the  
W3C public review.  These W3C specifications are therefore to  
beconsidered as work in progress. There may be some modifications to  
these event types in the JSR280 Maintenance Release to ensure  
alignment with the DOM3 Event types."

In general I don't think we want to set a precedent of locking in bad  
names in Editor's Drafts without a compelling reason. An  
implementation alone is not much reason, there would have to be  
significant content depending on it.

Regards,
Maciej

>
>
> cheers
>
> Chaals
>
> On Mon, 05 Nov 2007 21:34:50 +0100, Jean-Yves Bitterlich <Jean-Yves.Bitterlich@sun.com 
> > wrote:
>
>> Hi,
>> To the question in ISSUE-119 whether "[...] they already get  
>> implemented
>> with these names somewhere?", the answer would yes given that the  
>> Final
>> Release of "JSR-280 XML API" (http://www.jcp.org/en/jsr/detail? 
>> id=280)
>> defines the following methods based on the already existing names:
>>
>>
>> |boolean| 	|*getLengthComputable  
>> <cid:part1.04030001.07090808@sun.com>*()|
>>          Specifies whether the total size of the transfer is known.
>> | int| 	|*getLoaded <cid:part2.06010709.09060405@sun.com>*()|
>>          Specifies the number of bytes downloaded since the beginning
>> of the download.
>> | int| 	|*getTotal <cid:part3.02060700.06050607@sun.com>*()|
>>          Specifies the expected total number of bytes of the content
>> transferred in the operation.
>>
>>
>>
>> Charles McCathieNevile wrote:
>>>
>>> Anne opined, a while ago, that these two attributes should have  
>>> names
>>> more closely related. In my request for further information, nobody
>>> said they had any great reason for keeping the current names.
>>>
>>> I therefore propose to resolve this issue by changing the name
>>> "lengthComputable" to "totalKnown". Any objections?
>>>
>>> cheers
>>>
>>> Chaals
>>>
>> Jean-Yves Bitterlich, Senior Staff Engineer
>> Sun Microsystems GmbH, Sonnenallee 1, 85551 Heimstetten, Germany
>>
>> Geschäftsführer: Wolfgang Engels, Dr. Roland Bömer;
>> Vorsitzender des Aufsichtsrates: Martin Häring
>> Amtsgericht München: HRB 161028, WEEE-Reg.-Nr. DE 20803943
>> HypoVereinsbank München, Konto 31 625 009, BLZ 700 202 70
>>
>>
>>
>
>
>
> -- 
> Charles McCathieNevile  Opera Software, Standards Group
>    je parle français -- hablo español -- jeg lærer norsk
> http://my.opera.com/chaals              Try the Kestrel - Opera 9.5  
> alpha
>
Received on Monday, 10 December 2007 15:29:13 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:59 GMT