W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Nicolas Mendoza <mendoza@pvv.ntnu.no>
Date: Fri, 22 Dec 2006 06:04:49 +0100
To: "Maciej Stachowiak" <mjs@apple.com>
Cc: public-webapi@w3.org
Message-ID: <op.tkx22bvf4q17ch@agnus>

On Fri, 22 Dec 2006 02:48:45 +0100, Maciej Stachowiak <mjs@apple.com>  

> Based on this, I think that shorter names like "match" or "matchAll" are  
> justified, if not necessarily those exact names.

How about (document+"").match(/Document/) vs. (document).match() -- sure,  
a bit exaggerated but it sure seems confusing to me ;/

Oh and just because one has failed earlier doesn't mean that one has to do  
it again.

I'd go for surprising the user the least.

If one really wanted to always use short and possible conflicting  
keywords, one should at least do it properly, and deprecate the old long  
and oh so hard to use getElementBy#? ones. If it really is a huge problem  
that libraries make aliases that is.

Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
Received on Friday, 22 December 2006 05:04:57 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC