W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Anne van Kesteren <annevk@opera.com>
Date: Wed, 20 Dec 2006 14:51:05 +0100
To: "Joao Eiras" <joao.eiras@gmail.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <op.tku13fg464w2qv@id-c0020>

On Wed, 20 Dec 2006 14:45:56 +0100, Joao Eiras <joao.eiras@gmail.com>  
wrote:
> If you want to be accurate, the methods should be named
>
> getElementByCSSSelector
> getElementsByCSSSelector
>
> and be integrated with the CSS DOM module.

No, the Selectors specification is separate from CSS. Accurate and  
annoying naming would be:

   document.getElementByGroupOfSelectors
   document.getElementsByGroupOfSelectors


> There's one thing I don't understand ? Why returning a StaticNodelist ?

Because implementors indicated that doing live would probably not work.


-- 
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>
Received on Wednesday, 20 December 2006 13:51:22 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT