W3C home > Mailing lists > Public > public-webapi@w3.org > August 2006

Re: ACTION-195: updated mousewheel/mousemultiwheel proposal

From: Anne van Kesteren <annevk@opera.com>
Date: Tue, 22 Aug 2006 09:52:10 +0200
To: "Doug Schepers" <doug@schepers.cc>, "'Web APIs WG (public)'" <public-webapi@w3.org>
Message-ID: <op.teodg8i364w2qv@id-c0020.oslo.opera.com>

On Mon, 21 Aug 2006 22:58:26 +0200, Doug Schepers <doug@schepers.cc> wrote:
> | When "mouse wheeling" occurs, the implementation must dispatch a
> | <code>mousemultiwheel</code> event implementing the following
> | interface:
>
> I still prefer Bjoern's suggestion of "mouseomniwheel" since it indicates
> multiple directions, rather than multiple mice.

I'm fine either way.


> | wheelDeltaX is a number indicating the distance (positive
> | means rotated to
> | the right, negative means rotated to the left).
>
> I would say "indicating the horizontal distance".

Sure, changed.


> | wheelDeltaY is a number indicating the distance (positive
> | means rotated
> | away from user or to the right, negative means rotated
> | towards user or to
> | the left).
>
> I would say "indicating the vertical distance".

Sure, changed.


> Should we consider yoking wheelDeltaZ to zooming?

Perhaps, what do other people think?


> | The default value of wheelDeltaX, wheelDeltaY and wheelDeltaZ is 0.
> | UIEvent.detail must always be 0.
> |
> | XXX: wheelDeltaY -> wheelDelta?
>
> I thought we agreed that this model is not backwards-compatible, and  
> that we would provide a pass-through for "mousewheel" that would use  
> wheelDelta.

Backwards compatible or not, it might make sense for authors that the  
field has the same name. Granted, it makes a lot of sense to name it  
wheelDeltaY too... Removed the note.


> | For both <code>mousemultiwheel</code> and <code>mousewheel</code>
> | <code>MouseEvent.relatedNode</code> must point to the element being
> | wheel'd over or <code>null</code> if there is no such element. (For
> | example, when using some device without a pointer but with
> | some way to
> | wheel you'd get that.)
> | ===
>
> I like this part.  It will allow for context-specific wheel controls,  
> like dials and custom scrolling list, or zooming in on a particular  
> element.
>
> The wording could use some refining, but the intent suits me.  What about
> something like,
> "For both <code>mousemultiwheel</code> and <code>mousewheel</code>,
> <code>MouseEvent.relatedNode</code> must indicate the element over which  
> the
> pointer is located, or if there is no such element (in the case where the
> device does not have a pointer, but does have a wheel) the current  
> focused
> element, or <code>null</code> in the absence of an element."

The currently focused element is always available through  
document.activeElement. I'm not sure it should be integrated here as well.  
What's the use case? The rest of the wording seems fine though.

The proposal is now in CVS...  
http://dev.w3.org/cvsweb/~checkout~/2006/webapi/DOM-Level-3-Events/proposals/mousewheel.txt  
I should probably do something about the line wrapping but I don't really  
care at the moment.


-- 
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>
Received on Tuesday, 22 August 2006 07:52:28 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:55 GMT