W3C home > Mailing lists > Public > public-web-perf@w3.org > December 2011

Re: [RequestAnimationFrame] cancelRequestAnimationFrame is an odd name

From: James Robinson <jamesr@google.com>
Date: Thu, 8 Dec 2011 14:22:08 -0800
Message-ID: <CAD73mdJLxU6nteX81uZm8xPv9H1jcuV4EBKNRJLr30TBmKw=3g@mail.gmail.com>
To: "Karen Anderson (IE)" <Karen.Anderson@microsoft.com>
Cc: Boris Zbarsky <bzbarsky@mit.edu>, "public-web-perf@w3.org" <public-web-perf@w3.org>
Thanks for the feedback.  I've pushed
https://dvcs.w3.org/hg/webperf/rev/435e89478579 to the editor's draft to
rename from cancelRequestAnimationFrame() to cancelAnimationFrame(). You
can see the version of the spec with this change here:
https://dvcs.w3.org/hg/webperf/raw-file/435e89478579/specs/RequestAnimationFrame/Overview.html.
 I expect to update the WebKit vendor-prefixed implementation soon to
reflect this change.

- James

On Wed, Dec 7, 2011 at 9:58 AM, Karen Anderson (IE) <
Karen.Anderson@microsoft.com> wrote:

>  I like cancelAnimationFrame too, or some other variety where we don’t
> use “request” as part of the cancel function.  This will align better with
> the existing naming convention of timers which use [set|clear]API.  I am
> not sure I have a better “cancel” name either.  Other options I came up
> with are abort or dismiss, or even cancel as WebDevs are already used to
> that name.****
>
> ** **
>
> -Karen****
>
> ** **
>
> ** **
>
> *From:* James Robinson [mailto:jamesr@google.com]
> *Sent:* Tuesday, December 06, 2011 9:59 PM
> *To:* Boris Zbarsky
> *Cc:* public-web-perf@w3.org
> *Subject:* Re: [RequestAnimationFrame] cancelRequestAnimationFrame is an
> odd name****
>
> ** **
>
> On Tue, Dec 6, 2011 at 8:10 PM, Boris Zbarsky <bzbarsky@mit.edu> wrote:***
> *
>
> The name is a bit odd, if only because it's not really symmetric with
> requestAnimationFrame.  It took me a bit of staring at it to understand
> what it might actually mean.
>
> Would it make more sense to call this cancelAnimationFrame?  Or if we want
> to emphasize that only one request is being canceled, perhaps
> cancelAnimationFrameRequest?****
>
>  ** **
>
> Either sound fine to me.  The goal is to attempt some sort of symmetry
> with setTimeout/clearTimeout and setInterval/clearInterval.  I'm not sure
> if "request"/"cancel" are an ideal pair but I didn't come up with the
> "request" bit in the first place :).****
>
> ** **
>
> I think cancelAnimationFrame() would be a solid improvement on the status
> quo.  Does anyone object to this name?  If not I'll make an edit later this
> week.  These names are all so long and unwieldy that I'm afraid all
> libraries and authors will alias them anyway but that ship may have sailed.
> ****
>
> ** **
>
> - James****
>
>
>
> -Boris
>
> ****
>
>  ** **
>
Received on Thursday, 8 December 2011 22:22:38 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:04:32 UTC