W3C home > Mailing lists > Public > public-web-perf@w3.org > December 2011

[RequestAnimationFrame] cancelRequestAnimationFrame is an odd name

From: Boris Zbarsky <bzbarsky@MIT.EDU>
Date: Tue, 06 Dec 2011 23:10:58 -0500
Message-ID: <4EDEE752.1020206@mit.edu>
To: public-web-perf@w3.org
The name is a bit odd, if only because it's not really symmetric with 
requestAnimationFrame.  It took me a bit of staring at it to understand 
what it might actually mean.

Would it make more sense to call this cancelAnimationFrame?  Or if we 
want to emphasize that only one request is being canceled, perhaps 
cancelAnimationFrameRequest?

-Boris
Received on Wednesday, 7 December 2011 04:11:28 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:04:31 UTC